Quick Controls and the NI Kontrol MK2 not working

Is anyone using the native Instruments MK2 Kontrol Keyboard with Cubase? All is working generally well with one exception - I cannot set up the Kontrol keyboard to control Quick controls in Cubase (Track or VST). I’ve been able to set up other midi controllers with Quick controls, no problem. But in Studio setup, under Quick controls when I choose the NI Kontrol and choose “learn”, there is no change in the cc value. I can see a midi signal coming in under activity, but there is no response in the studio setup window.

The MK2 knobs work well otherwise, controlling NI plugin parameters, and learning midi controls directly from other VST plugins. Just no quick control.

The same is true for the latest versions of CB 8.5 and 9.5

Would love some help if someone out there has solved the problem. No response for several weeks from NI support.

You do not specify whether you are trying to use Track Quick Controls or VST Quick Controls. As VST Quick Controls were introduced with Cubase 9 and you report the problem with 8.5 and 9.5, I assume Track Quick Controls.

I also assume you mean assigning the Native Instruments Komplete Kontrol MK2 keyboard’s eight main knobs to the eight Track Quick Controls.

This is not something I’d done before. But I’ve just done some tests. I’ve successfully

  1. assigned the keyboard’s knobs to Track Quick Controls,
  2. mapped parameters of instrument tracks linked to a few different VST instruments to the Track Quick Controls and
  3. got the keyboard’s knobs to control the instrument parameters in all cases.

You do not specify which of the above three stages of the procedure is failing. However, I can suggest a likely pitfall that can affect both of stages 1 and 3. The MIDI button on the keyboard must be ON. This is the default except when the current VST instrument in Cubase is the Komplete Kontrol plugin.

If the MIDI button is OFF, the knobs do not send MIDI messages. So, if is OFF in stage 1, Track Quick Controls cannot learn the MIDI control change numbers of the knobs. If it is OFF in stage 3, the Track Quick Controls will not know that you are trying to vary values of the parameters they are mapped to.

Please let us know if this fixes the problem. If it does not, please provide some more details and I shall see if I can suggest anything else.

Simon

Just thought I’d chime in here and say I have the same issue. S88 MK2. Tried setting up BOTH Track Quick Controls AND VST Quick Controls in the “Studio Setup” Remote Devices. Tried setting MIDI Input to “Komplete Kontrol-1”, “Komplete Kontrol Ext-1”, and “Komplete Kontrol DAW-1”. NONE worked. Controller is set to MIDI mode. Followed instructions in user manual and it didn’t work.

Hopefully a solution has come up since the original post?

I’m away from my studio till mid-February. If the problem has not been resolved by then, I shall try to help again when I get back.

Solved! Not sure what I did… but i made sure to turn on Komplete Kontrol BEFORE launching Cubase and I also looked over my MIDI devices to make sure that the Komplete Kontrol items were all there and activated.