Quick controls Apply button

I’m following the manual’s instructions to set up Quick Controls, thus:


  1. Select Studio > Studio Setup.
  2. In the Devices list, select VST Quick Controls.
  3. Open the MIDI Input pop-up menu, and select a MIDI input.
  4. Optional: Open the MIDI Output pop-up menu, and select a MIDI output.
  5. Click Apply.
  6. Activate Learn.
  7. In the Control Name column, select QuickControl 1.
  8. On your MIDI device, move the control that you want to connect with the first quick
  9. Select the next slot in the Control Name column and repeat the previous steps.
  10. Click OK.


However “Apply” is greyed out and I can’t get past this stage. How to make “Apply” active?


It’s applied even without the Apply button. You can start to use it.

Hi Martin

Thanks for quick reply but sorry no it doesn’t seem to work. Neither does the learn button under the quick controls tab in the inspector on the left side. I am using Cubase Elements LE AI 10.5 with an Arturia Keylab Essential 61 MIDI controller. The learn function work with Stylus RMX, so it’s not the keyboard.


Does it mean, if you do the learning, the Quick Controls are not moving after?

They don’t move when I move the faders on the controller. I have submitted a detailed ticket to Steinberg.


Does the Address change, in the Track Quick Controls, when the Learn is enabled and you move the slider on your HW?

Hi Martin. Using HAlion Sonic SE, the 8 knobs in the VST Instruments rack, the 8 knobs on the instrument itself and the Quick Controls in the Inspector all sync even before I do the Quick Controls set up procedure in Studio Setup, so that’s good.

My hardware controller is sending MIDI data ( can see the indicator in the instrument). One of the faders moves the mod wheel randomly but that’s about all.

So then I go to Studio Setup/Track Quick Controls, hit Learn and hit the control name and then move the slider. The address does not move and remains the same (all 47 on Track Quick Controls, various addresses on VST Quick Controls.). Apply is still greyed out.

So it’s all working internally but the HW won’t map to it. I have seen Youtube videos show how to do it and the Apply button is greyed out until Learn is ticked. I was going to send you the links but this site won’t let me. So I have done my research! It’s all about finding out what is deactivating the Apply button.


Make sure, the MIDI Input is set up correctly in the Studio Setup > Quick Controls, please.

Hi again Martin

Please see a screenshot of the VST Quick Controls setup attached for you to check I have set it up right. The Track Quick Controls show the same picture but apparently “new users can only put one embedded media item in a post” so I can’t attach that.

Note that the “Apply” button is also greyed out on ALL devices in Studio Setup (Chord pads, MIDI, Remote devices, Transport, Video…)

Thanks for your willingness to help.




Thank you for the screenshot. It looks OK. I’m just thinking… Is the Mackie HUI using the very same port by any chance? Am I right, Arturia KeyLab Essential is using 2 virtual MIDI Ports? Are you in the DAW mode or in the User mode, please? In the DAW mode, KeyLab Essential is sending the sliders/encoders data overt the Mackie MIDI port (if I’m not mistaken).

Just ignore the Apply button, please. It’s a known issue. The button shouldn’t be visible, because it’s not needed at all anymore.

Hi Martin

I think I’ve sussed it. The issue wasn’t in the Quick Controls section, it was in the Generic Remote. I think you were right when you mentioned Arturia uses two virtual MIDI ports. As you can see from the pic, there is an “Arturia Keylab Essential 61” setting and a “MIDIOUT2 / MIDIOUT2 (Arturia Keylab Essent…” setting. When the latter option is selected you are able to control the instrument knobs using the faders on the controller. I haven’t got them to map perfectly yet, but at least I have them connected. I thought you’d like this feedback in case you get further enquiries about this subject.

In any event, thanks for your assistance in this matter.



1 Like