Quick controls, embarrassed already

Clean install of Win7, C7.06 and 7.5.

Keep having this:

Trying to control Artillery parameters (shown in the 3rd pic) with track quick controls using axiom 25. Turning axiom knobs to controls the QSs of the active/open track, but instead of the parameter shown what gets controlled seems to be something else on another track, e.g. in the pic groove agent SE4 (the first output ch volume)

These are my settings regarding axiom (generic remote for transport, vst quick controls for quick controls, nothing at track quick controls.)

What am I doing/is going wrong?
vst qcs.PNG
rewind.PNG
GASEArtillery.PNG

The problem is that the midi messages get both to the QC, the GR and the VST instrument itself.
Configure your axiom to send CCs that you don’t expect to see on a VST or if you can, have it split to multiple midi inputs. Try CC 101-108 for QCs. Worked for me with the Axiom 25 we have in class.

I have a Roland A500Pro, which has the cool bonus that it appears as two different devices. I’ve set the keyboard and pitch/modulation as Device 1 and the rest (knobs, faders, transport buttons) to Device 2.

Device 2 is routed to Generic Remote (btw, if you use the GR, just map the QCs there instead of in the VST Quick Controls).

If you can’t do that, map the buttons/knobs to a different midi channel (Ch16 for example), and filter them out on the midi / instrument channel input transformer.


And another P.S, Cubase has undocumented support for Soft Takeover / Catch mode if you fiddle with the GR some. Let me know if you want that and I could help.

Yeah, if all else fails, just use the input transformer.

Attached is a preset that turns CC21 into CC11. Extract it into your “AppData\Roaming\Steinberg\Cubase\Presets\Input Transformer\Controller Filtering” folder and change the controller numbers to whatever.

The downside is that you only get 4 of them at any one time.
CC21 is CC11 Preset.zip (558 Bytes)

Thanks for your time and expertise guys! I might be missing the full benefits from the latter, though (“Soft Takeover / Catch mode” :open_mouth:)…

  1. I changed the cc-numbers sent by the knobs to 101-108 to not send data to unwanted targets
  2. I set both the transport commands and the controller knobs (to QCs) in the GR
    (3. I also experimented with input transformer and modifying the preset by Plasuma)
    …to no avail, parameters changing all over the place.

So then I thought maybe I’ve misunderstood QCs and using GR for them.

My goal was to be able to

  1. select a track and
  2. immediately access the QCs for that track and the parameters set individually for it (“get default QCs from plugin” is awesome) by turning the Axiom 25 (1st gen) 8 knobs with no other parameters getting affected elsewhere in C.

Basically exactly the same thing as usual with instrument/midi tracks and data sent from a keyboard/PB/MW etc.

I went back to the device setup, set transport commands to GR and assigned the knobs to the Track QCs, didn’t connect anything to the VST QCs MIDI input.

Now everything is how I needed it to be, perhaps thanks to the CCs 101-108, not sure. Happy but confused…

A bit off topic, but I noticed your signature and got confused.

You state you have Cubase 7.5.1, but I’m currently at 7.5.0 and there is no update available to 7.5.1. Mistake or… are you some sort of betatester ? :wink:

Maybe Cubase Artist 7.5.1?

I haven’t got a slightest idea what you guys are talking about :wink:

Back to the topic: this might be related to the plugins also.

I’ve been trying to use CM Artillery (as an insert on a group of 4 outputs from GASE4) and most of my GR&QC problems got solved by the operations described above.

However, after loading the project, to actually access the parameters on Artillery (scap 1) I need to switch the output of the MIDI track in question to sthng else and back. After that I get the “get default QCs from plugin” button back (scap 2), which I then can click to activate the QCs (scap 3) and the connection between Axiom knobs and the parameter values.

Go figure. So far I haven’t observed if it’s the case with any plugin, but will let you know if it happens.
ArtilleryQCs 1.PNG
ArtilleryQCs 2.PNG
ArtilleryQCs 3.PNG

Now… The quick controls… :unamused:

I now have the generic remote working alright for transport using Axiom, but the track quick controls: as soon as I release the Axiom knob, the values jump back to around 50%. Except that the value cannot be read from the QC panel (see the image).

Any ideas?
QCsAgain.png