quick controls failing

I have a Oxygen 25 (025) which I want to use to control my quick controls for all the tracks in any project . This device is sending out transport and note messages successfully.

I have a project with an instance of Halion with an instrument loaded giving me eight default quick controls

I have followed this procedure:

In Device set up select Track Quick Controls or VST Quick Controls. What’s the difference? I have tried both.

Select Oxygen 25 as the input. Click Apply.

Activate Learn.
Select QuickControl 1.
Move a knob on the O25. I see the numbers change.
Do this for the other 7 knobs going down the list
Click apply and close Device set up

Then I go to the track, open the Quick controls panel (which has a blue light) and …nothing no ability to control via the hardware.


What am I doing wrong?



By the VST Quick Controls, you can control VSTis only. These control the 8 knob, you can see in the Rack.

Track Quick Controls are related to the track, and can control even VST plug-ins parameters, and other track parameters. So the Track Quick Controls are more universal, and I would recommend to use it.

It’s hard to guess… Could you provide some screenshots, please? From the Device Setup > Track Quick Controls? And also from the track, when the Quick Controls panel is shown?

weirder and weirder

Though the above does not work, clutching at straws I went back to the VST quick controls panel (Device set up) . In the MIDI status column I tried changing the first QC to “Programme change” and surprisingly it worked! Working my way down the list I changed them all to Programme change, you would think this would do the trick would you? No. The first six now control the quick controls, the seventh quick control is controlled by the eighth real knob, and the eighth quick control responds to nothing at all!!
I tried setting the Oxygen back to factory defaults and I get the same results


This should be easy…

Yes I will - been called to do some gardening by the wife


Hi Martin, your insight about Track controls versus VST controls helped. I realised that I had programmed both and they were conflicting. The changes to the VST Quick Controls I made = changing their MIDI status to ‘program change’ were simply disabling the control and allowing the other panel “Track Control” to work.
I then made some adjustments there - putting in numbers there and it seems currently to be working. I have set the VST quick control panel input to Not Connected.

This is not the first time you have helped me (and others) out of a jam




Yes, it’s a good idea to set VST Quick Controls to “Not Connected”, when you don’t want to use dedicated controls for it.

Btw, do you really use Program Change? Sounds a bit uncommon to me. I would recommend to use common MIDI CCs.

No I don’t use program change. I was using the two QC’s simultaneously and could not get either to work – setting to program change on one, got the other to work by (perversely) disabling it.

Martin, you seem to know what you are doing, may I pm a question. Ignore if you don’t have time. I shall understand


OK, I got it, now. Thanks.

  • i think you can download off m-audio site the driver for cubase
  • if that doesn’t work just do it manually from Device Setup->VST Quick Control using learn function

The driver has not been updated, since cubase five and instals into the wrong folder. Once it is moved it works

Isn’t the 25 just class compliant? Shouldn’t need a driver
Just connect VST Quick controls OR VST Track Controls (not both)
Learn knobs 1 to 8 and you are good to go .
The transport setting is a template, which you either load via midi devices, or quickly configure yourself, plenty of how to’s on the net.

This is not something I understand well (even after reading the manual) - your probably right.
I have three MIDI controllers. A Roland RD -700 NX (which I use for keybaord), a Korg Nano Studio - set up for controlling Ccs, and the oxygen set up to control Quick Controls. Everything is now working, though I stumbled through. I must say it is confusing and the manual is of limited help.

At the Mo, I have VST quick controls - not connected. Track controls set up for the Oxygen. I have Mackie Controls set up for the Korg Nano, M Audio has another entry for itself, and I have a generic remote set up for All MIDI ports and the Quick Controls. This is clearly overkill, but I dare not touch what I don’t understand if it IS working, which took days of labyrinthine wanderings!

I should like to know if there is a difference between a “driver” and an entry under the Remote devices column. Do all controllers need a driver? If you set up a “generic remote” or a “Mackie Control”, or for that matter hook up Track quick controls, is this sufficient? Or do you need a driver too?
I am also still confused as to why we need both Track Quick Controls and VST quick controls - when Track Quick controls (apparently) does include VST control.
It also puzzles me that each remote device presents different interfaces, A generic remote gives you a sea of choices, whilst the entry under M-Audio gives you practically none. Mackie is again totally different, as are Quick Controls.

Not easy!


You confuse a driver (how windows detects and names the device) with a a template (a collection of XML references of which knob should do what on this device)
That template you can make yourself in the generic editor, or load a prebuilt one from the internet.

In a more structured way:
If you only connect a keyboard to windows and do nothing else, it won’t do anything in windows, except the keybed
If you also define it as a generic remote, VST quick, or track quick, you can assign all knobs on there.
You can use one of the above, or any combination, as long as the assignments don’t overlap

So you can use the the generic editor to map your transport area and the VST or track to map your 8 buttons
Your keybed will keep working regardless, as long as it’s selected as midi input on the midi or instrument track, or is part of the group “all midi inputs”

Thank you Raphie, your post has helped but…
Yes I am confused. When I succeeded in installing the ‘driver’ (M Audios term) for the Oxygen, immediately and automatically, there showed up an entry under Remote Devices - but this is not a “driver?”. This entry looks pretty useless, as it has no way to map any pots, just entries for MIDI inputs and outputs and “smart switch delay” and “enable Auto Select”. I set it up for “All MIDI inputs” but what is this thing?


got a link? and maybe a screenshot of the app? I’ll take look.

you mean this one?

only needed if you want to use it as a USB to midi interface

Axiom 2nd Gen will work as a class-compliant device on Windows and will work for most people without the need to install a device driver.
For advanced MIDI use through the onboard MIDI In/Out ports, we suggest downloading this device driver for handling sys-ex and extensive control of external MIDI devices.


Yes. So, though it’s called “Direct Link” it is a device driver? Well as for delivering 'extensive control of Midi devices" - that depends what you mean by this (which is not clear) all it has is the inputs and outputs - no extensive control . When this was not on my system the Oxygen did not show up at all in the drop down menus, and if I recall correctly did not have a driver in device manager. So much for class compliance. Also it installs in a Cubase 5 folder, as mentioned above.
Whilst I am moaning about this ( :wink: :wink: ) I may mention a top secret of windows - Windows only allows 10 MIDI device ‘slots’, (one for each MIDI output and some devices have many) after this, it installs the device but does not show it and does not tell you anything, it simply does not work and leaves you guessing.
My Nano fell prey to this, as I had had several devices in the past the drivers had left part of their driver behind (without showing in device manager) .

I still do not know why some Remote Devices, look one way and some another.Yes, its to do with functionality, but the M Audio seems to have almost no functionality apart from connecting the input and output, the Mackie (which is not a Mackie) - but my Nano and the generic devices also differ.





This all seems designed to confuse the user Steinberg! The manual needs more explanation. It may be clear to those that regularly tread these paths but for those that have not, it’s a complete marsh!

thanks for the input


I just quoted the maudio website; you don’t need the driver unless you use the axiom din midi ports