Quick controls for VST instrument output channels....

Hi!

Is there an easy way to assign quick controls to inserts of output channels of VST instruments?
For some reason I can’t add QC’s for the inserts on those channels but I have found a workaround.

If I save the track preset and load it onto a ‘normal’ audio channel I can edit and add the quick controls for the VST audio plugins.
If I then save the track preset again and load it onto the VST’s output track the quick controls work but they are not visible in the QC tab of the inspector. I hope there is an easier way to do this. Any help would be hugely appreciated! Thanks!

It is working here. I tried Track Instruments and Rack Instruments both.
If I add an insert to the output channel and then go to the Track Quick Controls tab for that channel and select one of the Quick Control slots, I can select “Ins” and the audio insert parameters will show up there.

That is very strange…
QC.jpg
As you can see here I don’t have that option…
What am I doing wrong?

I just found out that they are visible in the mixer window.
Just not in the project window’s inspector.
It would be sweet if I could also see them there.

Right Click on one of the inspector tabs and then check “Inserts”.

I experimented with this a little more. Using a Track Instrument with multiple outputs enabled seems to behave strangely here also. If I create a Track Instrument and enable several outputs, I can add audio inserts in the mixer (like you, the audio insert tabs don’t appear in the Inspector in the Project Display). But, then when I go to the Inspector and select the Quick Controls tab, I do have and “Ins.” in the tree for selectable parameters but ONLY the inserts for the first output channel appear in the list.

To be honest, instruments with multiple inputs (i.e. MIDI tracks) and multiple output channels REALLY should be created as RACK instruments. Track Instruments with multiple outputs was meant to be a “cleaner” way to display the associated tracks but I think some functionality was lost at the expense of simplicity.

I honestly don’t know if this is a bug or intended behavior. Maybe I just don’t understand it because I use Rack instruments whenever there are multiple outputs.

Try creating your instrument as a Rack Instrument and see if that helps clear things up.

Another update…
It appears that Quick Controls can only access the Inserts of the MAIN output of the Track Instrument…
Interesting… Again, not sure if that is intended or a bug…
If I delete all the inserts on the main audio output (i.e. output 1) of the instrument, no “Ins.” is available for selection as a Quick Control parameter.

I just came across this thread trying to solve the same problem, all you need to do in Cubase 9.5 is click on the VST Output track in the inspector, click the settings icon (at the bottom) and make sure Quick Controls has a check mark in the options menu to make it visible.

Work-Around:
Create a group track, and route the output of the track instrument you want quick controls on to it. Then use the groups inserts and quick controls. Not ideal if you have a bunch of tracks setup like this, but it works.