Quick Midi Placement vs Different Tempos

HI, I’m back to using Cubase 6.5 after a long lay-off.

I wrote a couple midi tracks using Halion that comes with the program.
After I wrote the rhythm section harmony parts (gtr and piano)
I went back and put the melody in on it’s own track also using Halion.

Since I’m not a pianist, I did what I’ve done for many years.
I recorded the melody at a slowwww tempo.

but when I put the tempo back to where I recorded the other parts,
the melody moved to a new position and no longer respected the bars and beats that I had
recorded and quantized them to.

The midi acted like audio and moved.

Is there a switch somewhere that I need to turn off?

thanks, el profe

to add a little clarity, the midi notes are in place at the tempo they were recorded at.
When I change the tempo from fixed to track my midi either shrinks or expands depending on whether the other tempo is slower or faster.

The wacky thing is this:

I have 4 tracks I recorded earlier that act exactly like each other
but the opposite of the last track (melody) that I recorded.

I didn’t change anything, except add a midi track and record a melody on it with the other tracks muted
and at a fixed tempo (which was convenient since it was already slower).

When I recorded the accomp tracks there were some video and audio that was just piano vocal.
I created a guitar, piano and bass set of tracks to help with my arrangement of this standard tune.j
since it was recorded out of tempo, I used a lot of tempo changes to get my accomp to line up.

But when I was finished, I deleted all the audio/video and saved just the midi accomp.
I then deleted all the tempo changes and the tempo track.
All the midi now played in tempo.

I added the new track to put the melody for the lead sheet and all this tempo change stuff started getting wacky.


a lot of hours of work last night and today…now trouble…only thing I can do is print this out
and go to Sibelius to make a chart and enter every note all over again. arggg

any ideas on what went wrong?

el profe
el profe

so funny, I’ve not used C6 is so long I forgot about that little time base switch in the inspector window.

I was looking for that in the midi tracks window, but it’s only in the inspector.
I don’t recall switching it, but I do remember that the inspector is now no longer the default window next to the midi tracks but there’s the newer other window for doing things faster, yada yada yada and I do remember hitting those buttons trying to find the orig inspector window to turn the track down since the mixer wasn’t on screen at the time.

you gotta be careful

el profe

Living in So. CA it would have been nice to have gotten a quick answer when I called the support number,
but they said I had to go to my steinberg and fill out a tech support request…darn, whose got time of that.
When all you need is a quick answer.
Good thing my friend was avail for a quick solution. He’s usually not avail. So I got lucky this time. Ha!


It is also in the track list, if you configure it to be there.

Yes! There should be a switch on the MIDI track to toggle the time base betwen musical mode and linear.
The switch is a picture of a quarter note. If the switch is not visible, it must be hidden. Unhide it by right clicking (or mac equivalent) the MIDI track and selecting “Track control settings…”. Then move “toggle time base” to the “visible controls” column.