RAM Memory issue

Hi,
I have Cubase Pro 10.5 and run it on a Macbook Pro 2019, 16 RAM.
I kill all my other applications running, and deactivate all plugins in the session and still, I cannot even just play or record something as the sound is heavily ‘cut’ / lagging / struggeling.
Here is what it looks like: https://drive.google.com/file/d/1Mw51JpIImzp4sOzBqMPcYiJTDeRgiM8_/view?usp=sharing

Any idea?

has nothing to do with RAM…

Any idea what could cause this?

Many ideas… to much to list it here
a starting point would be the driver settings for the sound hardware, buffer size, ASIO settings in Cubase…

You can use the search function of the internet to get more information on this… we discussed this a million times already and always start with the same problems…
Having not all information makes a solid advice just guessing…

Yes sorry not giving more info about the set-up.
I use a Apollo X4 audio interface, so as I never monitor via Cubase, but always via UAD Console, my buffer is always at max so 2048.
Processing Precision is 64 bit float
Multi processing is Activated
ASIO-Guard is not Activated

For me this type of lag / cut must have been cause by RAM memory, but you seem to consider that it is not.

set your buffer size to 1024… just to try… and enable ASIO guard

what is the AD/DA clock sync source?

Console warns you that the source is not valid… it blinks red…
so this should be no issue… normally

Guys this is still not solved even when I activate Asio GUARD and I really don’t understand what’s going on, but it’s really annoying.
Here is another video capture: Screen Recording 2021-06-08 at 21.25.16.mov - Google Drive

Any help would be welcome.

I know get an [ Audio drop out error message ]…
Any help welcome.

Here is a link from another post. Hope it helps. Good luck !
tweak glitchfree pdf

You have not made this public so we can’t see it.

Are your OS, Cubase, and Cubase Project folder all on the same drive?

OS & Cubase App are on my laptop internal harddrive.
Projects and VSTs are in a external SSD 2T drive

This is a very important information… what kind of SSD?

Try to run a project without the SSD connected…

It’s the Samsung T7 2T

I can’t tell you what settings to use, but I would Google for information on optimizing your read and write cache for streaming for your drive (I assume this is still used on a Mac). Is your external drive connected by eSATA or something else (i.e., is the connection to the external drive capable of streaming your project in real time)? I’m asking these questions because the way your project is performing is like it can’t stream the data fast enough to play back in real time. It’s fine at first with whatever data is initially in the buffer or cache but as soon as that’s played it can’t be refilled fast enough to allow realtime playback. I’m on Windows so sorry I can’t give you more specific information, but I would research this from that angle until you can fix the issue or eliminate this as the problem.

SSD drive is plugged by USB C to a CalDigita, which is plugged via Thunderbolt.
Should be fast enough, no?

This was never the question… the question is, is it able to perform with low latency?
Could you try a project on the internal disk? Just for testing it…
Or connect the SSD to the TB port directly… this should use the USB mode to direct access the drive

And of course this could be your problem,
but it still can be something else… it’s difficult to make suggestions on such problems…