Random ASIO spikes causing audio drop-outs

After putting together a new system, I have been trying to figure out this issue for months now and nothing that I have tried seems to solve it.

When recording audio, or playing MIDI, I get seemingly random, periodic ASIO spikes which cause the audio to drop-out for a fraction of a second. The system is nowhere near being strained when the spikes occur.

Not only is this very distracting, it completely ruins audio recording (MIDI is doable).

What I have tried:

  • Disabling Network Adapter (also trying various driver versions and driver only installs)

  • Disabling on-board audio and Nvidia HD Audio (in device manager, BIOS, and Nvidia control panel)

  • Disabled variable CPU clock speeds and power saving features in the BIOS.

  • High performance power profile (USB selective suspend ‘off’, System cooling policy ‘active’, HD sleep ‘never’, display off ‘never’, sleep ‘never’.

  • Turned ‘Indexing’ off on all drives

  • Updated Intel chipset drivers

  • Tried various Intel USB driver versions

  • Updated BIOS

  • Updated firmware on UR824

  • Tried different Yamaha/Steinberg USB drivers for UR824

  • Tried removing all plugins from Cubase and re-adding them 1 at a time

  • Disabled ASIO Guard (and tried it on various settings)

  • Tried different buffer settings

  • Analysed system with DPClat and LatencyMon for an hour with no DPC spikes

  • Tried various Nvidia driver versions

  • Upgraded videocard (same issue with GTX760 and GTX970)

The next thing on my list is to buy a mains powered USB Hub and run all of dongles and other USB devices from that and only have the UR824 and a mains powered external HD connected directly to the main board.

I’ll update this list with more things that I have tried, as I am sure I have done more to eliminate this issue, but no luck so far…

If anyone can help, I would be incredibly grateful.


I also upgraded to 8.0.20 yesterday and am now experiencing the same issue. I wish I knew an answer to your problem. I had this issue with my previous homebuilt windows pc and it was a real nightmare. I never managed to get rid of the ASIO spikes. I suppose you have tried DPC latency monitor etc?

Yes. dpclat is all green. No DPC spikes. Same with LatencyMon, which gives more detail on processes and their latency levels, but it is saying I shouldn’t have any problems with audio recording/streaming.

Do you have your PC connected to a wireless network by any chance? I have a Home network set up over wireless to a laptop running Win8.1.

When transferring files over the network I have observed some strange performance issues on the Win7 desktop.
I am wondering if it could be causing issues. I will delete the homegroup entirely and see if that makes any difference also.

I was wondering if it might also be a Logitech wireless mouse and keyboard. Perhaps the wireless USB dongle interfering somehow.

It could also just be an issue with the Gigabyte (GA-Z97X-Gaming 5) motherboard and it’s BIOS or drivers.

I am off work from tomorrow for a bit, so will do some more testing. The mains powered USB hub should arrive tomorrow.
I will also try disabling my overclock completely and running the i7 4790K at stock speeds and voltage, without turbo boost disabled, then I will report back.

I am determined to figure it out. This build is turning into a real pain though. USB3, and the Z97 Haswell motherboards are turning out to be very disappointing in terms of stability and reliability.

same here, DPC also proves that eveything is fine in system

Just an update. A mains powered USB hub arrived today and I moved my wireless mouse and keyboard dongle, eLicenser and iLok onto the hub.

I had no audio drop-outs for about 10 minutes of playback, loading intensive plugins to strain the system a bit, cycling through presets etc. and thought that the issue had gone away, and then they randomly kicked in with no apparent cause.

The only other thing that I can think of is to disable hyper-threading in the BIOS, but apparently that will invalidate my entire Native Instruments library and means that I will have to reinstall, update and reactivate hundreds of GBs of software, just to try a potential solution for ASIO spikes…Ridiculous process.

It appears that I spoke too soon. The ASIO spikes and audio dropouts have mysteriously returned after less than 24 hours and are as bad as ever.

I reset the BIOS to it’s defaults, re-enabling hyperthreading and the various C-states. I am now eliminating them one at a time to make sure that they are not the culprit.

I have also tried uninstalling Avira antivirus and Comodo Firewall, but the issue remains.

I had some issues like this with Cubase 7.5 on my new WIN 8 PC build. In my case, the problem was tied specifically to the CPU power management settings. I disabled everything I could find in OS and Bios related to CPU power saving and the problem was resolved. I just updated to 8.0.20 and no issues yet to report.

Clearly you’re aware of this and accordingly have made changes to your system to address this. However, it maybe worth another look around for some setting that was overlooked, or that may be getting reset by a 3rd party program trying to “help” with system efficiency.

Thanks for the reply.

After resetting the BIOS to it’s optimized defaults, I disabled all CPU power saving C-states apart from C-3.

The Asio spikes and audio drop-outs were consistently worse, so I disabled C-3, which consequently disabled Intel Turbo Boost and automatically overclocked the CPU to 4.4Ghz.
It’s stable at 1.2v, and the temps are fine (bit hot for my liking, but it is well within the limits and it is very warm here in N.Ireland right now).

This on it’s own may have (apparently) solved the issue, but now I am wondering if it has been an issue with BIOS settings for the USB ports themselves.

xHCI mode defaults to ‘smart auto’. I changed it to enabled. Disabled limits the USB3 ports to operating as USB2 ports.

Apparently xHCI hand off and EHCI hand off have to be enabled as well. EHCI hand off was disabled, it is now enabled as well.

This may have been the problem all along, as Win7 does not support USB3 natively. These settings at default (and whatever I had them as before I initialised the BIOS) could well have been causing both the USB 2 and 3 ports on the motherboard to misbehave.

It’s too early to say, but while playing the game Shadow of Mordor I would usually experience the audio drop-outs on a fairly regular basis, and after playing for an hour or so there, I experienced no drop-outs at all.

The audio for this game is coming through the UR824 into my studio monitors. It’s proved a useful way to test for the presence of this issue, as decapitating hundreds of orcs is a great way to vent my frustration! :smiling_imp:

I’ll report back after more extensive testing in Cubase with some VSTi. I am hopeful, but I am also wondering if my hardware is too modern for Win7 and this is a sign that it’s driver support is starting to wane.

Switched the UR824 out and tested with a USB bus powered Focusrite Scarlet 2i2. Issue is gone…Seems like the problem may actually have been being caused by an old freezer in my kitchen.
Previously, when the compressor in the freezer kicked in, it would caused my HDTVs screen to go black for a second and then it would come back on. Now it appears that it may be doing the same to my UR824 audio interface.

I ordered a new fridge freezer today as the old one really needed replacing. If it is not that, then it is a fault in the UR824 or it’s power supply. Will report back.

New fridge arrived, tested the UR824…Problem is still occurring. Nightmare. Seems to be a problem with the UR824 hardware.

The only thing I can try now is the UR824 with a different computer to see if the problem persists, then I will know for sure if it is hardware or driver related.

Just to update this thread. I was able to finally resolve this issue.
I had a Win8 Pro upgrade code that I had bought, but never used.
I did a clean install with that, updated to Win8.1, installed all of my device drivers, chipset drivers etc. And now the issue is no longer present (so far, anyway!).
It would appear that it was either an issue with USB 3 not being natively supported by win 7, or poor USB 3 drivers from Intel, or poor win 7 support for the motherboard chipset, which required a hotfix to be installed first before the chipset drivers could be installed.

Although it could also be an issue with the UR824 USB drivers, because the Focusrite Scarlett interface worked perfectly.

So, if you put together a new system but are still using Windows 7, be aware that this could potentially cause you a lot of issues. Thankfully Windows 10 is a free upgrade, but this could (will most likely) bring its own headaches until it matures a bit.