Random Beach Balls

Hi All,

I have a random question, so sorry for its generic & boring nature. I’m on 7.0.7, Mac 10.8.5, latest everything, 32GB RAM, Intel 12-core.

Most of the time I’m writing, I get random beach balls. Whenever I start or stop playing, try to select a certain tool (glue, scissors, mute), try to set locators, go from Arrange to Edit window, etc. Just random acts that are literally BASIC GUI functions to navigate Cubase; nothing out of the ordinary what-so-ever.

These “stalls” usually take about three to five seconds or so, and I’ve noticed that the disk on my VST performance window generally spikes after Cubase “wakes back up” as it seems that Cubase had to render/read/write something before it moves on. It’s very strange. It usually happens maybe once every 10/20 minutes or so-and though I’ve learned to be patient it’s becoming increasingly frustrating. It reminds me of when I was on Logic, and I’ve never really had this in Cubase.

I have lots of Kontakt instances loaded with some other synths, usually a decent amount of plugins on tracks as well-but with the hardware in my machine and the preferences I’ve set, I would imagine it should handle these tasks easily.

Has anyone had these random beach balls? I’m considering trashing the prefs, but I REALLY don’t want to lose my key commands since I can’t figure out for the life of me how to import a .xml file for the key commands I’ve already saved.

Any help would be greatly appreciated!!

E

Aloha e,

A couple o’ shots in the dark here.

1-Are you running Cubase (and yer Mac) @ 32 or 64 bit?
2-Are you using a traditional spindle/rotation drive or SSD? (spindle drive might need de-fragging)
3- Did this prob just start recently? If so what changes (hard and software) have you recently made?
4-Have you considered upgrading your OS to 10.9x?
5-Done basic maintenance? clear caches/run ‘cron’ scripts/repair permissions etc.
the free app Onyx is helpful for that stuff.
https://www.macupdate.com/app/mac/11582/onyx

{’-’}

Do you use auto-save? If so try disabling it (but remember to save your project frequently!!)

Hi Erick,

To add to Curteye’s post, try checking your “Energy Saver” settings under System Preferences. There’s an option “Put hard disks to sleep when possible”. You need to uncheck that option if it is checked. This usually solves the problem.

Another possibility is the frequently discussed save/load time with big projects containing loads of plugins and VSTi instances. It can be especially frustrating when “Autosave” is activated in Cubase preferences. A work around could be to disable autosave, but you need to remember to save your project frequently. In this case, YOU choose when to wait for the project to save.
My ideal solution is to use VE Pro and remove all the burden of VSTi’s from Cubase and put it on VE Pro. IMHO VE Pro is a must for every serious composer with big projects these days.

Good luck.

Possible let up a little on the ganja?

What’s a ganja?

An app? a plug?

(Just looked it up)

Oh!!! THAT Henny’ Youngman’! ‘Ba doom boom’.
:slight_smile: :slight_smile: :slight_smile: :slight_smile:

The Beach Ball is something that OSX throws up when it runs out of processing power (and can’t keep up). There are several possible causes for this. The worst it that a bug throws the program into a loop, which usually leads to a crash.

One possible cause is that you simple is asking more of your computer model is capable of. Keep an eye on the performance meter. It may give you an indication of whether or not you’re demanding too much of your computer. Judging from your description, this sounds like a plausible cause.

Upgrading to Mavericks (10.9) may help. as it has a more efficient memory handling than 10.8. Best of all, it’s free! Installing more memory might also help. Especially if you’re using heavy sample libraries.

In the worst case, your computer is not up to the task, and needs to be replaced.

Hey all-thanks so much for the replies! I’ll try a few of these suggestions and get back to you shortly!

  1. 64 bit on both :slight_smile:
  2. Traditional Drive, 7200 rpm
  3. I’m not sure of any hardware changes I’ve made, and I’m constantly upgrading and updating software in the hopes that more and more bugs will be fixed (or introduced, if the glass is half empty)
  4. I did consider that, but other than a couple small aesthetic changes I’m not really too keen on upgrading-I’ve yet to hear of the benefits outweighing 10.8.x in any fashion. That being said, I’m DEFINITELY open to hearing suggestions and/or success/fail stories with that new OS
  5. I haven’t tried that “basic maintenance” stuff but I will shortly! Thanks.

Thanks Cpechet1-I DO use autosave, but have never tried disabling it. I’ll do that now and see how that works out. I’ll keep you posted!

Since a couple people have mentioned it, I’ll definitely turn it off…thanks guys. And yes, “Put HDD’s to sleep is unchecked” - thanks!

Because you said:

I’m constantly upgrading and updating software

Theses types of ‘constant’ installations can cause mucho drive fragmentation.
This causes the ‘read’ head on the drive to be jumping all around the drive looking for parts (fragments).

While this ‘jumping’ is going on the OS is just sitting waiting/twitling it’s thumbs
and showing beach balls.

So If you have not done so (for a while or at all) try de-fragging your hard drive.
I use ‘iDefrag’ on my old G4 laptop but ‘Drive Genius’ or ‘TechTools’ are great products as well.

Or if you have a 2nd drive capable of holding what is on your internal drive,
just copy everything over and then copy it back. ‘Works a treat’.
‘Afro engineering 101’. :slight_smile: :slight_smile: :slight_smile:

With SSD’s coming down in price, I look forward to the day when all 'puters
can consider de-fragging like old school de-magnetizing of tape heads.

I’ll look back and think to myself; Wow! We won’t have to do that any more!
It was a ‘black art’ anyway.

Good Luck!
{’-’}

With SSD’s coming down in price, I look forward to the day when all 'puters
can consider de-fragging like old school de-magnetizing of tape heads.

I’ll look back and think to myself; Wow! We won’t have to do that any more!
It was a ‘black art’ anyway.

Good Luck!

Thanks so much Curteye-that actually made me laugh out loud :laughing: - That makes a lot of sense. I think I’ll probably defrag and see if that helps overall speed/latency issues with my machine. I’m very pleased with it’s performance (mid 2012 model) and try to keep it very clean if I can, but I’m sure a defrag is most certainly needed by this point.

But I DO have other good news-I disabled ye-olde Auto-Save and have been working for about 45 minutes now with no beach balls! I haven’t gotten one beach ball since I turned it off; very cool indeed. I’m a worrier when it comes to losing work so I usually save a lot out of habit, so I guess that does it for now! That’s a real shame because auto save is SUCH a great feature, but my beach balls got to the point of pretty frequent/annoying.

Just another question though-would increasing the save time (i.e. from 10 mintues to 45 minutes) be a better solution? In an ideal world I’d love to keep auto-save on but if I have to turn it off, I think I will…

THANKS GUYS!

Think of ‘saving’ like playing an interval on you keyboard.

My left hand stays ‘locked’ in ‘thumb/index finger mode
and every few seconds I am constantly playing:
‘Command S’ ‘Command S’ ‘Command S’ ‘Command S’ ‘Command S’ ‘Command S’
You get used to it.
{’-’}

That was it then. Your computer appear to be a bit underpowered. I get intermittent beach balls (that lasts for a second of two) quite often when I open (larger) VST’s/VSTi’s. It’s OSX’s way of telling me to “hang on for a second” while I finish this task.

I have never gotten any beach balls because of the AutoSave though. It’s not that processor intensive. There may be “a problem” with you harddrive interface. But on the other hand, then you should see beach balls when you do a [Command]+[S] aswell, one thinks. Are you using an external USB drive, or something like that? If so, try to save your project to an internal drive, and see if this affects the AutoSave beach balls.

Saving huge projects is slow, especially if you have some VEP pro instances inside ( if you dont “decouple” the VEP instances, Cubase saves all the vienna ensemble pro metaframe informations into the project )

If you have lot of VEP instances, it can take up to 20-30 seconds.

But still, even without VEP, saving project can be slow. Maybe some optimization needed from Steinberg :wink:

You are correct! I’m getting a Beach Ball when I save (every time) in Cubase, but that’s expected because the projects are so big (sometimes :wink: ). So it seems the beach ball recurring at weird periods was when the computer was trying to Auto-Save the project. I’d be very surprised if my machine was “underpowered” for these sequences-especially since I’m running everything in 64-bit and have ample RAM. I’m wondering if my preferences in Cubase (i.e. multi-core support or hyper threading) are somewhat off that it can’t utilize all of my cores properly/processor power accordingly…

RPA-I’m wondering if that’s what I mentioned above-the multi-processor support in Preferences or something like that. Surely they would have given the user to “optimize” their machine.