random layout changes when adding text/tremolo strokes don't change

Hello there

I’m still quite new to Dorico, but so far I’m having two reocurring issues.

  1. in a piece for 6 instruments, I wanted to write ‘senza vibrato’ for the viola, but when I actually try to add that piece of text, all of the staffs in this system (there’s only one system on the page) spread out so much (vertically) that the lowest staff disappears under the end of the page and I can’t reach it. Can anyone make sense of this? Or tell me how I solve it?

  2. when I want to change some four-strokes single-note tremolo to three-strokes single note tremolo in a line of tied notes, there are always some notes that refuse to make that change. Then I have to untie them first, in order to make the change separately on that one note and then re-tie them. This seems unnecessary and takes a lot of time. Any leads?

Many thanks in advance!
Best regards

Welcome to the forum, Vigdis. The first problem sounds like a bug to me. Are you able to zip up and attach your project here so we can take a look?

When you create a tremolo on a tied note, Dorico will show an appropriate number of strokes taking into account the note value of the note. You can, however, adjust the number of strokes for each notehead in a tie-chain independently if need be: switch to Engrave mode and you can select each notehead separately, then adjust the number of tremolo strokes via the Properties panel.

Thanks, here it is! I wanted to write the ‘senza vibrato’ in the very beginning of the viola part.

About the tied notes with the tremoloes: I have some tied notes which are all the same value and still some ended up having four strokes instead of three… anyway I already changed each of them manually by untying them first (before I read your reply, that is :slight_smile: ).
what remains unspoken - ensemble.dorico.zip (1.26 MB)

I can confirm, it happens here too. I found that when I change the layout options under Page Setup / Flows / Show flow headings to ‘Never’ the page is displayed correctly. But when I change this layout option back to ‘For all flows’, the viola staff is forced off the page again, even after saving (in 3.5.10) and reopening. And that is regardless of removing the page overrides or leaving them as they are.

Unrelated side note: some systems with low notes and/or pedal lines protrude through the bottom margin (like on pp. 9 and 13). I think Dorico should try to avoid that. There’s plenty of room in this score.

Another side note: all of the pages have page overrides in Engrave Mode. When I remove the overrides, the only difference seems to be the mention of “Flow 1” in the header. If, instead, you change the Default master page to not include the {@flowTitle@} token, you can avoid the overrides, and don’t end up with a lot of empty pages (I guess you didn’t add them on purpose).
Your first page has manual overrides for the title etc. I’d suggest leaving the text tokens (like {@projectTitle@}, {@projectComposer@} etc.) on the First master page as they are. The dynamic content for that kind of information can be edited in File / Project Info.

Do you know there’s a (free) update from 3.5 to 3.5.10 (.11 on Windows)? It doesn’t fix the bug in your example, but the update contains several other bug fixes and optimalisations.

Dorico follows the general music publishing convention that the top and bottom staves on “full” pages are always at the same vertical position.

The amount of space above or below those staves depends on the score (e.g. a cello or bass part at the bottom of the page has at most 2 leger lines below the staff, but a piano part will usually have more, plus pedal lines etc). Set the margins in Layout Options to fit the music onto the page.