Random notes turn red after saving in version 3

This is just an observation/possible bug report, though not an urgent problem as it’s easy to solve.

I opened a Dorico 2.2 file in Dorico 3. It looked perfectly normal. Saved it, so it was now automatically converted to D3 format.

Later opened the new D3 version & noticed in the harp part some notes were randomly turned red. This was nothing to to do with voices or being out of range for the instrument or being accidentals or anything obvious. Easily cured by selecting all the notes & changing the colour back to black (though some tied notes had to be untied first), but I’m not sure why it happened.

Otherwise… love D3. My personal wish list is for a) adding control over fermata playback length to the bottom panel and b) implementing smooth glissandi in playback. I’m sure these are in the pipeline in due course.

Read the version history. It’s not random at all - it’s telling you that those notes are out of range because you’ve not set pedals correctly. It’s telling you that you’ve written an F# but your F pedal is set to play F natural, for example. This is most definitely a feature, not a bug, and the “cure” is to use the new Calculate Harp Pedals function, not to go through changing red notes back to black.

1 Like

Thanks Leo that’s really helpful and betrays my ignorance. To be honest this particular part is actually intended for an electronic keyboard with a harp button pressed.

The last time I wrote for a proper orchestral harp was about 4 years ago, and I took a lot of time and trouble to sort out the pedalling. However when it came to the first performance I nervously asked the harpist if it was OK and she said I needn’t have bothered as she preferred to look at the part beforehand and work it out for herself.

Still that’s all very reassuring, thanks again.

You can turn off View > Note and Rest Colors > Notes Out Of Range, though obviously that affects all instruments, not just Harp.
If you’re writing for keyboard with a harp button, why not use a Keyboard instrument, then assign it to a Harp sound in Play mode? You could even go Edit Names from Setup mode and rename it as “Harp”. That will then bypass the Harp Pedalling function.

Yes of course. Though in this case, at different times in the piece so far the keyboard player is pretending to be a xylophone, a harp & a glock (& will also possibly be in charge of the gunshot SFX). Now I know what it is, it’s not a problem at all, and next time it looks like we can afford a real harp player I’ll know what to do!

That shouldn’t make a difference. You presumably currently have one Player who is holding the following instruments:

I’m suggesting you have one Player who holds the following instruments:
Keyboard (renamed Harp and set to play a harp sound)

Thanks, I can see that’s the thing to do.