Random Tracks Added to project.

I don’t know how to search for this solution so i’ll ask here.

When I use drum plugins ,the done thing is to drag the loop over to the track you want ,
When I do this though a new midi track is created in the project. There no data in the track but its named by the loop i just dragged into my instrument track.

It’s annoying to scroll down and see you have to delete 15 empty midi track so i wondered if there is a simple way to fix?

Hello,

You can use Project Logical Editor (from the Edit menu) and it’s preset: Delete empty tracks. Or you can use directly the preset of course: Edit > Process Project Logical Editor > Tracks > Delete empty tracks. In addition, you can assign your own shortcut.

is this, what you are looking for?

No I want it to stop creating empty midi tracks when all I am doing is dragging grooves from my drum plugins into the projects drum tack.
Every time I add a loop from addictive Drum it create an empty midi track.
Every time I drag a loop from Steven Slate Drum 4.0 it creates an empty midi track.
Strangely, when using Studio Drummer it does not create an empty loop though i’m very sure it’s done it before.

Oh I see, sorry to my incomprehension!

However, you have the solution, how to delete them very fast. :wink:

great! :unamused: :laughing:

I don’t know if this is the same, but every time I load up a VSTi it axes me if I want to create a MIDI track. I think there is a box in the Preference file that if checked will skip the asking bit and just create one. Maybe your box is checked?

[And thanks for that hint Martin - I am reading all about your enthusiasm for the PLE in this forum, and who knows, you may be the one to make me crack that book!]

Alexis, what you wrote, this is little bit different. This is feature of Cubase. What HarrySound, it is bug of Cubase or plug-in, or cuommunication between them, I think.

This creating a new MIDI track is helpful very often. It is not very frequent (in my opinion), you load up new VSTi and don’t want to create new MIDI track.

But if you want, you can switch it off in the Preferences > VST > Plug-ins > Create MIDI track when loading VSTi: Always / Do not / Always ask to.

About PLE: I’m pleased. :wink:

I have had this happen to me with superior drummer 2.0 harry

must be a bug in cubase? not had a look into it so can’t help!
But maybe if someone from Steinberg reads the thread they can see it’s not just you experiencing this.

When I drag and drop midi loops into the project if I choose to drag the loop to an existing midi track it creates an empty midi track below it…sometimes it loads up hallion se in my vst instruments all by itself when I drag in the midi part.

Not every time though? But it does always add the midi track

Cheers

Try this … Preferences -> MIDI File -> uncheck “Auto Dissolve Format 0”

Hit the Help button on the Preferences menu for more info.

Scab, thanks, you rock!

Thanks Scab. Was tearing my hair out. Dont know how this changed but it worked. Cheers again Mate