Randomly jumping tempo lines

Many times, and seemingly completely randomly, tempo lines like rit---- accel-- etc are jumping from their spot where Dorico placed them by default. Most of the time they jump down and cover up the staff. When I drag them up again, the systems are being pushed up (like magnetic layout kind of effect…). Even after correcting this many times, they still behave this way. Is this a bug?

It certainly could be a bug, but you need to provide a minimal, reproducible case so that we can investigate it.

It’s difficult to predict why it happens, all I can say that after having it dragged to the correct spot, moments later it’s on top of the staff beneath it again. It happens in the project file I posted for you recently.

It’s not only the tempo lines, but also for example the word “a tempo”, so maybe tempo text in general. One consistent thing I noticed is that when I correct the position, save the project, open it again, the text is on the wrong spot again.

just a wild guess… could you be trying to add tempo text to a staff that’s set not to show it…?!? :slight_smile:

Not sure what you mean, I cannot find a staff option that can hide dynamics. And when I turn on the View Signposts/Dynamic, there is nothing strange to see. Here is what I saw after opening the previously corrected tempo text: screenshot
Screen Shot 2017-01-08 at 17.47.54.png

If there are staves above the ritard, you’d need to show them too for anyone to make a evaluation. If you want tempo marks and tempo alterations below the top stave, you should be aware of the Layout Option setting below.
tempoMarks.png
There is also the question if, after you have tried to modify so many aspects of your files (fonts, etc.) the program rules can operate as they were intended. So be sure to try this on a clean file if only as a demo.

Thanks for the info about the System Object Position in Layout Option setting. For the piano part they are set to appear above the staff as you can see in the screenshot I attached with this post.

To show what I experience all the time I made a short video: https://youtu.be/CijbuKfIefQ

It shows how I add the tempo text and drag it to its correct position. When I use the Reset Position from the Edit menu the Tempo text jumps up to the staff above. After dragging it to the correct position I saved the file and opened it again, as you can see, the positions are wrong again. This happens all the time, very frustrating…
Screen Shot 2017-01-08 at 20.38.32.png

Your video is cropped so tight that I can’t see what you’re doing. In future, please include the whole window so that we can see more of the context.

You should be able to avoid this problem by correctly specifying the desired length of the gradual tempo change from the outset, rather than dragging the right-hand end of it in Engrave mode. The problem with doing that is that you’re not changing the actual notated length of the instruction, but rather just its graphical length. When you create a gradual tempo change from the popover when the caret is active, the gradual tempo goes in at four quarters in length, no matter what else you do.

Instead, don’t show the caret before you hit Shift+T to open the popover: rather, select the note at which you want the rall. (or whatever) to start, and Ctrl+click the note at which you want it to end, then type Shift+T and enter the tempo marking. Provided you tell Dorico both where the marking should start and end, you won’t have to drag it around in Engrave mode.

You should of course be able to adjust the notated length of the rall. line in Write mode using Shift+Alt+left/right arrow, or indeed by dragging the end of it, neither of which is yet implemented, but both are planned for the near future.

Thanks for the info, Daniel. I did as you said, but things still feel very unstable. There is always some reason to adjust a position, but at this stage it’s impossible because just selecting the rall line makes it jump up again covering the above staff. I am sure it will be fixed in future updates.

We can’t fix something that we can’t reproduce, unfortunately. Please attach the project file here (zipped up) and make another video showing the whole window, and we’ll have another go.

My guess is that it will be something to do with the fact that when you drag the right-hand end of the tempo marking in Engrave mode, it still remains the same length from a spacing and collision avoidance point of view, so something is then getting upset, but I’m unable to reproduce the problem in a project of my own making.

I played around with it a little more, and it looks like the only reason the tempo text jumps up (no matter how I created it in the first place) is when I drag the right side handle on the line. It’s a little annoying, but not a deal breaker. This is something that will be fixed in a feature update you mentioned, so for now I know how to avoid this from happening.

again, I have this problem: tempo objects that keep jumping away from the position I placed them. I created them by selecting the area I want them and choose the Rall. line from the panel. It looks good at that moment, but after having done some other editing or going to another mode or close and open Dortico, it looks like this:
Screen Shot 2017-07-29 at 15.17.08.png
Selecting them and choosing Reset Position, gives this result:
Screen Shot 2017-07-29 at 15.27.59.png
EDIT: I figured it out, the jumping happens when I try to move something in Layout mode. It doesn’t matter what or on which page. In this example, I tried to move the fermata to the last rest in the piano bar. The moment I use Alt-Arrow on them, the tempo jumps up:
Screen Shot 2017-07-29 at 15.34.33.png

I’ll need to see the file itself to diagnose what’s going on here. Please zip it up and attach it.

My guess is that you’ve dragged the start and end positions of the line in Engrave mode, and as such the lines are being positioned according to their default length and thus they’re ending up getting pushed unnecessarily far away from the staff, though that should mean that they go back to their normal places when you use Reset Position, which of course you’ve tried. So to actually work out what’s going on I need to see the project, and not a picture of the project.

No, all I did was add the lines and after that moved an object in Engrave mode somewhere else. That is enough to make them jump. Here is the file:
1 - Rushing.dorico.zip (455 KB)

Here is what I see every time, makes it very difficult to adjust things afterwards:
https://youtu.be/qLNwmIvob4o

Not an explaination as such, but an observation. After having done Reset position, I did Engraving Options/Tempo/Vertical Postion … Prefer horizontal movement…

That resets the position I see, but still it jumps away when moving an object in Engraving mode.

Daniel,

This is a distinction that I had not fully appreciated. Do you mean by the “notated length” the length that will affect playback in this case? Because from the point of view of producing a printed score only, making it look correct could be considered all that matters. More generally, it would follow that all changes to the text that are not cosmestic should be made in Edit Mode, and that changes in Engrave Mode are intended exclusively for cosmetic changes that are needed to negate a default (i.e. Dorico determined) placement.

David

I was able to do it by first finishing the score and at the end adding the tempo objects. Although I had also the problem that when editing a tempo object, the other one is jumping. Not an ideal situation.

André, there’s definitely a problem of some kind with the specific combination of gradual tempo and fermata which we need to look into further.

Yes. Edits made in Write mode affect where Dorico thinks the item is semantically, and also affects where it thinks it is from the point of view of collision avoidance. Edits made in Engrave mode are purely graphical in nature.