Range edit doesn't work with Edit-in place Midi?

Range edit seems to work well with Midi. Excellent. But I often edit Midi-in place and Range edit doesn’t seem to work that way (unless I am doing something wrong). Anyone else try this? Thanks, Ed


What exactly have you tried to do, please?

I had a simple test project with one audio track and one midi track. Entered some notes from keyboard. Then used edit in place. Tried to use the range tool. Drew a range, tried to move it. Nothing happened (though the range was highlighted). Then held ALT key and tried to copy a range. Nothing happened there either. As I said in original post, the range tool did work with midi in normal mode. But with in-place it didn’t. Is that by design?

In my case Range edit doesn´t work in Edit in Place when the Combine selection tool is enabled.
I guess this is a bug?
Another thing I can´t do is show lanes in Edit in Place. Another bug?


I can confirm. Reported to Steinberg. Thank you.

1 Like

Thanks Martin. Thought I was doing something stupid.

The other issue is that scrolling horizontally, while Edit in Place is active, badly corrupts the ruler, at least on Mac.

Hi and welcome to the forum,

Could you attach a screenshot, please?

Sure. I notice this only on my M1 Mac, I have an Intel based iMac that doesn’t seem to exhibit the problem:

To reproduce, open Edit in Place and then scroll the arrangement horizontally.


Thank you very much. Now I can reproduce it too. Reported to Steinberg.