Range Tool - Exclude Row & Select All Vertical Should Follow the Grid Snap Setting

Issue:
The Range Tool’s modifier actions “Exclude Row” & “Select All Vertical” do not follow the grid snap setting.

Feature Request:
Make the Range Tool’s modifier actions “Exclude Row” & “Select All Vertical” follow the grid snap setting.

Thanks