Re-Record mode not removing previous takes

When I’m recording a section, I typically keep going until I have the take that I want. Since the last take is all I need, I thought that re-record would do the trick. What I’m trying to do is cycle through a section multiple times with the end result being only one take saved, the last one I recorded before stopping.

On page 239 of the manual under Common Record Modes, it describes re-record in this manner:

In this mode, the recording is reinitiated, the events are removed and recording is restarted from the exact same position.

However, when I turn on Cycle and make a couple of passes, instead of removing the previous take and re-recording, I still get multiple lanes of the various takes.

Am I not understanding this feature properly? I’d be grateful for any suggestions on how I can achieve the “save last take only” recording that I’m trying to accomplish.

“Re-Record” works when you hit the “Record” button on the transport. Take a look at the options available in the “Audio Record Mode” section (pg 244 in the op manual) to see if any of those options are what you want.

Since I’m not sure what you are recording (audio or midi) I’ll mention there are similar settings for midi record mode & midi cycle recording too. Take a look at those (starting on pg 250 in the op manual).

Regards :sunglasses:

Hey, PRock.

Appreciate the help.

I’m recording audio and yeah, I was looking at the wrong section. However, after going to Audio Record Mode, I’m still getting unexpected results.

Cycle History + Replace
Existing events or portions of events that are overlapped by a new recording are replaced by the new recording. However, if you record in cycle mode, all takes from the current cycle recording are kept.
Existing events or portions of events that are overlapped by a new recording are replaced by the last recorded take.

I’m doing cycle recording and don’t want to keep all the takes in a given cycle, just the last one. Cycle History + Replace does what I’d expect, it keeps all the takes.

Replace mode sounds like what I want, but here’s what happens in that mode.

  1. Cycle button on
  2. Press Record
  3. Play guitar for take one
  4. At end of cycle region, it loops back to the beginning of the region to start take two. The event for take one disappears, and the event starts growing for the recording of take two. So far, so good.
  5. Press Stop a couple of bars before the end of the region so that it doesn’t rewind to start take three. The event that was recorded for take two disappears, and is replaced by the event for take one.

I tried again, this time doing three takes. While recording it looks like it’s deleting the previous take each time but at the end of three takes, take one is what remains.

So everything behaves as expected in Replace mode, but once I stop it doesn’t keep the last take, it keeps the first one, which is exactly the opposite of what I’d expect.

The idea is to use Cycle mode to keep recording until I get a take I’m happy with, then stop and have that take (i.e. the last one) be the one that’s save, with all previous takes being deleted so I don’t have to go through and manually delete all the other unwanted lanes each time. It sounds like that’s what Replace describes, but the behavior doesn’t line up with that.

Is there another setting somewhere that I don’t have configured properly?

If I have mine set like listed below and hit stop before the recording cycle I want to keep finishes, I end up with only that last recording remaining (all previous takes are removed except for the one I hit stop on). However, there is a weird behavior that I’ve gotten used to in CB Pro 9.5… It frequently changes the size of the last wanted event so I have to drag the right end of it to expand it back to it’s original size. This behavior does not happen in CB Pro 10 (not sure if it was a fixed issue or what).

Common Record Modes set to “Re-Record” & “Start Recording at Left Locator”
Audio Recording Mode set to “Replace”.

Regards :sunglasses:

Just had a chance to test it again. With my settings matching yours exactly, I still get the bug. What version of 9.5 are you using?

Anyone else using 9.5 on Windows 7 who can report their experience with this mode of cycle record and perhaps offer thoughts on some other setting I might be overlooking?

I have CB Pro version 9.5.41 running on the latest Win 10.

Regards. :sunglasses:

I’m on Windows 7 but other than that we’re running the same thing. Can’t imagine why it would behave differently.

Ran another test today. Same results as before where take one is recorded, then on the loop that event is deleted and an event for take to begins. Then, on stop, the event for take two is deleted and what remains is the event for take one.


Thinking about what you mentioned, I dragged the right edge of the take 1 event to the right. What I saw was take two following take one. So what’s happening, at least on my system, is that it’s apparently recording all takes in a single audio file.

Maybe that’s the way it’s designed. “Replace” apparently refers to the event, not the underlying audio file, and we’re both experiencing a bug with the resulting event. In your case, the last take begins where it’s supposed to be, but you have to drag the right edge to show the full event - is that correct?

In my case, it just reverts to showing the first event. To work around in order to get the last take, I’d have to expand the event all the way to the right, count back the number of measures from the end to get the exact beginning of that take, cut it, delete the left event, move the right event to where it’s supposed to begin. That’s far more hassle than keeping all lanes and doing the same sort of delete / copy / paste exercise since at least the lanes are all in the right starting point.

So, this particular feature is obviously buggy. Since they’re probably going to do one more maintenance release on 9.5, did you ever report this as an issue so that it could be addressed? Don’t want to create a duplicate if you have.

Yes… in my CB Pro 9.5.41 the last recording (event) is the one saved at the correct starting point and I had to drag the right edge to expand it to get the whole event to show/play.

As far as submitting an “issue report”… I never did. And I don’t remember seeing others having the issue you (or I) have.

Again… CB Pro 10 works correctly.

Regards. :sunglasses:

Cool. I don’t know if it’s too late for the final maintenance release, but I’ll post this as an issue in that forum, linking back to this thread to avoid redundancies. Maybe we’ll get lucky. :slight_smile:

Thanks for all the help!

Like I mentioned, I don’t remember seeing others complaining about this issue. I would think a bunch of users would be voicing their concern if it was widespread.

Your issue is slightly different from what I described on my system. That makes me think it might be related to some kind of installation problem rather than a bug.

Maybe the way for you to go is to put in a support request in addition to posting the topic in the issues section. Who knows but, maybe the support staff would have a suggestion to quickly assist. It can’t hurt to do both and give yourself the best chance of a fix.

Regards. :sunglasses:

That’s not a bad idea, although I’ll probably move to 10, which you’ve mentioned doesn’t have the problem, on the next maintenance release if it fixes some problems that I care about. I reported the issue mainly because I make a living as a software developer, so if I can reproduce a bug and don’t report it, it’s bad karma. :slight_smile: