Re-Record Not Erasing Previous Take

When using the re-record function with an audio track the previous take is not erased.

  1. Re-record, pre-count, start recording at left locator and keep history are enabled.
  2. Set up stereo or mono audio track.
  3. Start recording and hit re-record and it will return to the left locator and start recording again without erasing the previous take.

This happens on 8.010 and 8.020.
Disabling preferences didn’t help.
This function works properly on a midi track.

Hi,

it works here, on my system (Mac OS X), as expected. When exactly do you hit the Re-Record button? Is it during the 1st cycle (I expect, you are recording in loop), or during another next one? The 1st take (or the previous one, which is not erased) wasn’t there, before you start the recording, right?

Is it necessary to have exactly this setup? Is it the dame, if you disable pre-count, or if you enable Start at Cursor? I just wonder, if any of this settings affects it, on your system (I tested it in the exactly this setup, you described, of course).

Thanks Martin for testing and for your ideas.
I usually use re-record when I mess up right away before the loop has cycled. I have the same problems when cycle is off.

I tried it with pre-count off which caused a different problem:
When I hit re record it returned and disabled record still not erasing what I just recorded. But when I hit it an additional time it erased the previous take and recorded.

I tried all of the above with start at cursor enabled.
I additionally tried turning off asio guard, different buffers on my RME card, pre-roll enabled, and with cycle on and off. This is also in an empty project with just one audio track and no plugs ins.

This concern (or similar to it) has been reported. For me re-record works as you mentioned when re-recording through the mixconsole. It works properly when re-recording throught the project window. Maybe that can be the workaround for you too until they fix it. Here is the link to what I posted if you want to add to it.

http://www.steinberg.net/forums/viewtopic.php?f=233&t=82735&hilit=re+record

Regards. :sunglasses:

Well I hope Steinberg fix this issue soon. I was using it with a footswitch linked to a CC121 and with that setup it is a superb feature when it works. However I have unfortunately given up using it because of the problems.

Any update from Steinberg on this? Will Re-record be fixed in a future release?

I haven’t heard anything from Steinberg but… mine started working correctly from the project window and the mixconsole after I upgraded to release 8.0.30.

I reported it here about a week ago and it is still working today.

http://www.steinberg.net/forums/viewtopic.php?f=233&t=82735&hilit=re+record

Regards :sunglasses:

Thanks Prock, and I put a reply in that other thread.

Anyway, I still can’t get it to work in my 8.0.30. Sometimes it does not delete, sometimes it does not return the cursor to the recording start point.

Sorry you are still having this issue. Thanks for updating the issue thread. :wink:

Regards :sunglasses:

I’m still having the same problems with re-record in 8.030.