REAKTOR bug fixed in C6?

For me the process priority issue with Reaktor where solved with the Reaktor 5.5 update. It was a very frustrating problem indeed until I learned this workaround:

  1. Open up the project that is using Reaktor.
  2. In the “VST Audio System” settings in Cubase change the “Audio Priority” setting from whatever you have to “low” and click Apply.
  3. Change the “Audio Priority” setting back to what you had before, in my case “Normal” and click apply.
  4. Done.

I had to do this each time a project was opened or a new instance of Reaktor was added to the VST instrument rack.

Sincerely
LarsErik

I don’ thave this problem with Reaktor 5 (greenish-blue in color, came with Komplete 7) on C5.5.2 and the latest version of Reaktor. I used to have big problems with the older version of Reaktor 5 (gold in color, found in ealrier versions of Komplete), but not this one. So perhaps it’s the version of Reaktor and not Cubase.

I actually had the opposite problem. What ensembles are you using? I’ve noticed this ASIO spiking problem only happens on certain ensembles…

I have had this same problem too since Nuendo 4 I dont’ remember ( I actually started a thread on the NI forum about it).
Apparently it only happens to a few of us, and NI is working on it, but it has been hard since they haven’t been able to replicate it in house… they haven’t given up afaik…

quesiton though for those who have it:
do you have any NI hardware and if so which ones?
thanks
rsp

no NI hardware here, just Komplete 7.

ok thanks.
rsp

I have Maschine and Kore 2 controller…I know about the “fix” changing the audio priority…but it’s a PITA …and a total workflow kill…I’ve just been avoiding using Reaktor…though in my last project I needed a vocoder track…so, I did battle with the “work around”…and bounced it to audio then removed the instance of Reaktor…ugh

Finally a solution to the Reaktor/Cubase problem!
:arrow_right: http://www.native-instruments.com/forum/showthread.php?t=120272&page=3

I’ve been using JBridge for the last month or so, and I’ve been able to run all of the Reaktor ensembles ~99% reliably. Including adding Reaktor “player” instances like The Finger/Mouth/etc to existing projects that use over 2GB of RAM.

I’m guessing this works because hosting the VST through JBridge gives the instances their own allocation of RAM space and processor time, instead of hosting it within Cubase’s… (in task manager the JBridge hosted plugs have their own processes called “auxhost.exe”).

I guess you could say I’m using a 32-bit plug with a 32-bit DAW, but with JBridge as the mediator and it seems to be working well.



YES! I can confirm that JBridge DOES solve the problem! I just bridged Reaktor 5.5 to the 32bit version of Cubase 6 and it works great!

I tried it in my most CPU and RAM intensive projects and Reaktor (both instruments and effects) worked flawlessly… I’m so happy I can FINALLY use Reaktor again!



Same here. I’m using J-Bridge to bridge 32 Bit Reaktor 5 to 32 Bit Cubase 5 Host. It works great! Thx J

Just tried it out myself and it works great! No more random ASIO spikes and crackling :slight_smile:

Anyone else has crashes when loading ensembles? Even when I have playback stopped and low CPU in general (almost empty session).

Thanks.

Is this before or after you tried the J-Bridge solution?

Before. Just tried jbridge yesterday and it works. Tanks!
Confirmed bug by steini or ni?

:slight_smile: Yes,it’s more stable now.
Thank god we have jbridge!!

How can Steinberg fix a problem caused by another company’s bugs?

Is no-one allowed to complain to NI about their products?
As Monty used to say, “If you’re parrot’s dead what are you doing shouting about it in my cheese shop?” Because it has no cheese doesn’t mean it’s a pet shop. :mrgreen:

People are complaining to NI too…but it’s odd that one guy (João Fernandes) and not these 2 mega-companies have the cure (also for bridging)…and they didn’t bother fixing it.

They should be complaining to NI. It’s their problem and it’s not just with Cubase. And they’ll let you complain here until you’re blue in the face because Steinberg won’t fix someone else’s problem and NI doesn’t have to if no-one’s complaining to them.

J-Bridge? I doubt he knows how or why J-Bridge fixes it. If he did then the programmers at Steinberg and NI could make a lot of people happy very easily. No?

Because NI say it’s Steinberg’s fault.

And does NI also say that the issues with other DAWs are also not their fault? And why does everyone believe them?
See, the title of the thread says “Reaktor bug…” NOT “Cubase bug”.

Muddies the water just enough so nobody need give anyone a clear explanation and a hands up fair-cop-guv answer.

What issues with other DAWs? Do you even know what you’re talking about?

Hi everyone,

I have problems using midi-controllers (NOVATION Nocturn + Automap).
Each time I turn a knob to change a parameter in Reaktor, I get short drop outs.

Best wishes

J


Windows 7, 64bit / Cubase 6 / NI Komplete 7 / Reaktor “jBridged”

I’m not saying I do believe them, but they are being just as stubborn as Steinberg on this. Steinberg say “it’s NI’s fault - we’re not going to do anything”. NI say “it’s Steinberg’s fault - we’re not going to do anything”. Us users in the middle get the shaft. Both parties need to stop being so stubborn - whenever such issues have come up in the past it’s always turned out both parties need to work together to fix it.