Real-time peak maxing only when instrument track selected

Hey guys…
I’m getting some strangeness where Cubase (win8.1) is popping & clicking & totally maxing out the real-time peak whenever I’m sitting on an instrument track. If I select an audio track, it goes down to nothing. The project itself is sitting under half load on the cpu meter.
That suggests it seems like it’s ‘waiting’ for me to play something on whatever instrument I’ve selected, and ‘prepping’ for it or something, hence the real-time load going through the roof only when a VST track is selected.
Anyone aware of or noticed this problem?
I’ve tried multiple buffer sizes & ASIO guard settings. It changes things. But doesn’t get rid of the problem.
Cheers, Ad

Hi and welcome,

Ny default, when you select the Instrument track, it is Record enabled. So the ASIO-Guard cannot by applied.