Real-time peak spikes when right zone VSTi tab showing

When the right zone is shown and the VSTi tab is the active one, I get a heavy increase in real-time audio performance peaks. When I activate any other tabs - Media, CR or Meter, the peaks go down. Same if I just hide the right zone. This was driving me crazy as a project that was fine all of a sudden had clicks and pops all over the place. I turns out it was because I had randomly activated the VSTi tab.

The exact same project in Cubase 9.5 is fine. There’s no difference whatever tab (including VSTi) is shown in the right zone.

This clearly can’t be right? Anybody else noticed this? I’ve seen some posts about people getting clicks and pops in 10 but not 9.5. Maybe this is the reason?

Seems though like C10 is gives you slightly higher loads on the audio performance meter in general.

Could anybody please check if you have the same issue?

It seems to be working fine here. I can’t see a noticeable difference in real-time peaks whether the VSTi tab is activated or not.

Thanks for checking!

Ok, that´s interesting. Wonder what is going on here then…

hi! I faced some random real time peak spikes too during my audio recording and even midi inputs! Indeed it is very annoying and it does interrupt the whole recording or arranging process. After digging into posts regarding this matter, I realize there is a possibility cubase can be affected by GPU.

This is my laptop spec
windows 10
16GB ram
GTX 1050

I was looking up and down for the “appropriate” working GPU driver that is compatible with cubase (I am using Cubase 9.5 Element), however it failed me!

Ended up I disabled the GPU through the “device manager”
Viola, it seems working to me! Healthy “real time” and close to zero spikes.

I did 2 full session audio recording, it spiked for the 1st recording. Hence, I adjusted my buffer size to 128 (9 ms latency), and whole thing works like charm!

I hope this help!

IMO, unless you are actually recording a Virtual instrument, where lower latency is needed, keeping your Samples setting at 1024, or even 2048 while mixing, recording vocals, etc will eliminate spikes, stutters, etc. When finished recording VIs, either render the VI to audio and turn off the VI, or at least freeze the active VIs. You can always go back during the mix and fix your VIs and re-render. Your computer will thank you.