Real-time Recording Anomaly

Bars 2-3 and 4-5 are identical. Or should be. Step-Time entry and playback work fine. But in Real-Time record mode, everything below that B or B-flat sound but are not appearing on the staff.

Anyone have a clue what’s going on here?

Dorico5 file attached.
bass oddity.dorico (529.8 KB)

I don’t know why you have this problem, but I just tried with your file, and the notes are written down when I’m on real time recording…

1 Like

Marc, you are the best Dorico Detective. :+1:t3:

At first, I thought this might be a problem with my keyboard, but then why would Step-Time entry behave normally?

1 Like

It would be helpful to see the actual MIDI data that Dorico is getting when you record. If you’re on Mac, please run the Terminal and paste in the following command:

open "$TMPDIR/Dorico 5/MIDI captures"

and hit Return. That should open a Finder window containing the MIDI files captured during real-time recording.

So please try and record that descending scale once more, then zip up the contents of the MIDI captures folder and attach it here.

You are the Absolute Coolest, Daniel.

Recorded as requested. Didn’t ZIP, as the file is 155kb.

capture 0001.mid (155 Bytes)

Thanks. The MIDI file looks good, and if I drag and drop it into Dorico myself, all of the notes in the MIDI file are correctly imported. If you drag and drop the MIDI file into the piano roll in the Key Editor, do all the notes appear?

No, they don’t. I get the first two notes, then nothing. Most strange.

Aha, you must have a MIDI pitch range filter applied in the MIDI Import Options dialog – try dragging and dropping the MIDI file onto the Dorico icon so the dialog appears, and check in there what pitches you’re filtering out, if any. It’s in the lower section of the dialog, which you will need to expand.

Okay. Success in import. How does this affect Real-Time recording?

Never mind. Tried recording again and we’re completely back in business.

This is why you are All-Time Dorico Rockstar. Many thanks.

1 Like