Realtek ASIO Driver: "Audio hardware removed"


Sometimes I need to use the inbuilt sound card on my laptop with Cubase Pro 9, and so far the Realtek ASIO driver and hardware has worked perfectly. Until suddenly today…Cubase keeps displaying that “Audio hardware using Realtek ASIO was removed from this computer”, and if I select the Realtek ASIO driver, of course there’s no sound, and latency values in Device Setup are 0 (unknown). Yet the Realtek driver and hardware are working fine with other applications, and nothing has changed since a couple of days ago when the Realtek driver was still working well in Cubase also; the driver and audio settings in Windows (10) are all running perfectly.

I’ve tried fixing this for hours now but no results. Would anyone have any idea what could be the problem? Why doesn’t Cubase recognize the driver and hardware when all the other applications do?

Incidentally, the Vista driver for my external sound card (my Edirol UA-5 is too old but it’s been running well in Windows 10 using the Vista driver) started having problems after the recent Creators Update for Windows, with the sound disappearing for good after 5 minutes and me having to restart the sound card every time, but then the problem went away by itself a couple of days ago, and now the driver is working perfectly, without me having had to do anything. Now, I wonder if this “fix” has something to do with the Realtek not working in Cubase anymore since they happened around the same time…can’t see any logic to it, but then again, the way these systems behave often tend toward illogical… :wink:

Thank you!