Rearranging staves/systems


How can I swap two staves and also two systems? I would like to swap woodwinds and Strings so that woodwinds shows at the top of the score? I oredered the players from the top to bottom but it did not get reflected in Write or other modes!


That’s very odd. Can you attach the project?

If I can figure out how to rename my project to “Cannot rearange”, I will. But I cannot do it.

  1. I renamed the file name on windows Explorer ( file system)
  2. I removed the project names, … in Engrave mode.

However, the project name shows up in the dropbox the top left corner of Play mode and also old title contatinated with new one ("Cannot Arrnage) shows up the Dorico project window (title at the top left … G in Cannot Rearrange) I am showing the


This is super wiered. Is there a meta data stored somewhere that I cannot get rid of the old name?

PS. Why there is a drop box in the top left of Dorico in Playmod? Can we play back mutliple project from the player? I am sorry, I am new to Dorico.

Open the Project Info dialog if you really want to see the names of things: Ctrl-I

Don’t worry about the text etc. It could be to do with tokens (which you don’t need to worry about yet but we can help with that later).

Can you just attach whatever you’ve got?

1 Like

@Chikitin, are we seeing the Full Score layout? or are you showing another layout? Could you attach your project please, problem will be solved much faster.

It shouldn’t really matter which Layout; the score order would be the same wouldn’t it? It will be interesting to see what is going on.

Daniel, in principle you are right, but one can change this order individually in Layout Options->Players->Uses custom player order.
We need to see the project. :crystal_ball:


Yes - I forgot about that!

Thank you. That wasn’t straigh forward!

I had to create a new flow! copy the one I wanted to rename to that, they delete the main one!!

Cannot Rearrange.dorico (468.6 KB)
Here is the project. The notes, … are removed.

You have a custom layout specified. Remove it and all will be good.

Oops, @k_b solved even without the file (impressive)!

1 Like

Thank you. Yes @k_b did resolve it. Now I know about customs. By the way this is the way to go in my opinion to rearrange staves. Much better than Finale.

Well normally you could just drag players in the order you desire in Setup mode. I’m not sure why this Custom player order was enabled - if you did it (accidentally), for instance, but otherwise you wouldn’t need to get involved with “custom player order”.

You can just do a File - Save as in order to save a Project as a different name from within Dorico itself instead of getting involved with Windows Explorer.

well, I was composing from scratch and had not idea what instruments will be use later in my composition. I started with Strings, and then added WWs. I suppose my process triggered custom player order.
I had tried the Save As and still the name was showing up! I was so frustrated and tried file explorer :slight_smile. But I learned my lesson thank to you all. :pray:

Dorico has the urge to sort added instruments by its presets - unless you have deactivated this sorting compulsion :wink:
In Setup Mode make sure to change the sorting order to None. If you add further players, they will be added at the bottom of the list, but you can just drag them to the place you want them.
That way you completely avoid going into Layout Options and set up a custom order.

Being allowed to set a preference for none is close to being my top feature request.


Hmmm, on Mac when you do a Save as, the name shows up highlighted and when you type the new name it replaces it. I assume Windows would be the same?