Recalculate music frame breaks

I have a situation in which some pages has too many systems, and they clash into each other:

(In this example the right page is clearly wrong because staffs cross each other)

I expect Dorico to automatically handle it, and insert a “frame break” (or “page break”). How do I force Dorico to “recalculate layout” to fix it?

I tried:

  • Format music frames > Reset Layout
  • Staff Spacing > Reset Layout
  • Note Spacing > Reset Layout

I also couldn’t find any solution with a quick online search.
It’s possible I changed some of the layout options or engraving options that caused this to be messed up. LMK what I options I should revisit to fix it.

I recently had the same problem and discovered this response from Daniel via pianoleo that explains why it happens and how to deal with it but it isn’t quite as easy as adjusting your settings.

I would just add a Frame Break at bar 73.

Dorico does an excellent, job, but occasionally needs a bit of help.

1 Like

Dorico can’t always completely resolve these kinds of situations entirely on its own without your assistance. This video goes into a lot of detail about how to master the vertical spacing features of Dorico:

Without seeing the project file itself I can’t say exactly what you should do, but perhaps you need to reduce some of the values on the Vertical Spacing page of Layout Options, or maybe slightly reduce the staff size.

Or possible increase the gap between systems.

I started watching this video, and apparently I had “Casting off” set to “Fixed number of systems per frame” :man_facepalming:. So obviously Dorico did the best he could :sweat_smile:
Thanks a lot!

1 Like