"Receive file lost connection" when Get HD Files pressed

The title says it all. I did some recording and then I wanted to get them into the session. I press the button for Get HD Files and it start but the byte count never goes over zero. After a bit it pops up “Receive file lost connection”.

It can’t be an internet connection speed thing. I’m using it in a local LAN setup. Both VST Connect Pro and the performer are the latest versions as of today.

Any ideas?

That’s strange. I don’t have that issue here on LAN. Can is ask. Do you have an offset start time in your project?

I had some issues with this but maybe not related. The dev team are working on it. Just a thought to try setting your project to start at ‘0’ in case the offset is the cause.

Shot in the dark really.

Is that error repeatable all the time?

It was repeatable all last night during testing. I tried rebooting both machines and tried to get files for hours with no luck. This morning, I tried it again and it got four out of five hd files. I have no idea what happened. I’m thinking that there was a connection I had not downloaded from a different performer that might have been the fifth hd file that would not come over. I deleted all files and started over again. This time it appeared to work. There were other issues like it seemed that only one of the two channels was recorded but I got it twice. Anyway, that’s a whole other issue to resolve. Someone should create a video tutorial that goes into detail of how it all works and what to look for when it goes wrong. It took me way to long to understand that what I get in my session is only a low quality MP3 of all their tracks and the way to get the individual tracks in full resolution is to get hd files.

It’s a very cool app that could have great uses. The documentation is just poor. I really thank you guys for jumping in and helping me understand it more.

I saw this a while back, it appeared to be project specific, and when I deleted the project folder on the Performer side, or started a new, empty, HD files downloading worked again. Sorry- I haven’t actually tested it. Once it worked for me, I just carried on. Posting fyi in case it helps.

I just had a 90 minute session and when we were done, I went to Get HD Files and again I got the Receive file lost connection. Is there something special about when you can get the files? It seems like it should work without an issue but the byte count stays at zero and it times out. I was still connected to the performer and we could talk while I tried to get it. Let me know if there is some step I missed in getting the files. Fortunately, he found the files on his computer and can send them to me if I can’t get this working. Other than this Get HD files issue, the session went without a hitch.

‘byte count stays at zero’ - would you happen to know roughly how large the file in question is?
Possibly the filename has characters that get in the way.
If you can repeat this, we would be very happy to get the Cubase project file (just the .cpr file, no audio etc) and performerProjectXXXX.xml of the performers’ folder with the project name (XXX stands for a bunch of numbers).
Maybe just the latter is sufficient, along with the filename in question. Sorry for the inconvenience, we definately want to resolve this.

Thank you for the help. I will get that information together and host the files somewhere you can get them.

Here is a time limited link to the data requested. I had the performer send me his entire VST Connect performer directory. There were no audio files in it, even though VST Connect pro showed that there were 8 files to download. That’s a bit concerning.

We spend another couple hours on it tonight. Even made a new project to run the test. Still didn’t work. I had the remote performer reinstall the software on his Mac. The next try worked. I have no idea why the Mac did not record the HD files but said it did. I will be testing more. That’s a pretty big issue if you finish a session and find there are no audio files to get.

Thanks for the files. There are no recordings registered at all, that is certainly not good. We are having a closer look right now. Any hints as to how to reproduce this are very welcome.
“I had the remote performer reinstall the software on his Mac.” How exactly did he do that, just run the installer again?

Yes, he just ran the reinstaller again. He did not remove any preference files. He also did not move the original into the trash. He just ran the installer as normal.

Before he reinstalled, we did try rebooting both computers. In the original project, it still showed the HD audio files that needed to be downloaded to the studio but it still failed. I deleted all the tracks in the session and tried again. Still no success.
We then created a new project and tried that. Still didn’t record the tracks to the remote hard drive. Then I had him reinstall and it worked right away.

I’m not sure if it’s a Mac issue or not. I believe he is running Catalina.

Are you using VST Connect SE? Or maybe you did before?
We found that the “Get HD Files” option is active in the SE version, which is a bug. That would explain a lot.

Nope. I use used VST Connect Pro at all times. One thing Idid not mention was that I am running it in Nuendo 10.2.20.
I really do appreciate the help. Thank you!

Experiencing identical issue (am using Cubase Pro 10.5 (latest update) and VST Connect Pro latest update)

check version 4.0.43 (hopefully out today). If the problem persists, report again or write a PM.

Thank you musi!