Record Arm Disable

Is there an automatic setting to stop the Arming a Track for Recording when you click on it?
This is actually the biggest CPU Juice drawer when you click on a track, it usually goes up by 10%.

Preferences/Editing/Project&MixConsole uncheck the enable record on selected track (Audio and MIDI options).

regards J

Thank You Sir!