Record Audio with Tempo Change?

Hi all,

So for a LONG time, Cubase has been complete garbage at tempo changes where the CPU will spike, Audio will drop out, missing midi, etc. It’s getting ridiculous (in my humble opinion of course) and obviously Steinberg should be able to fix something as simple as having a computer not freak out when someone decides to use different tempos in their sequence.

That said, I’m just trying re-record something into Cubase but the end of the phrase happens right where I’ve got a tempo change. Normally (in 6.5 and 7) I would just have heard a pop/click thing where the CPU spiked. That workaround was simple enough-just go into the audio file and remove the pop, do a little crossfade, and then I was back in business.

In C8 however, I’m getting a message: “Recording Error: Audio drop out detected” It just stops my record right then and there and basically just gives me a giant middle finger. I’m sure someone much smarter than I has found a workaround and I’m just curious as to what it is!! Is it like exporting an audio mixdown? Or the new Bounce in Place function? I usually just record via a little loop I’ve created from Cubase --> PT --> back into Cubase (just for simple quick audio bounces) but I don’t think I will be successful with this during a tempo change.

Any help would be sincerely appreciated!! Thanks all!

E
Screen Shot 2015-04-27 at 1.08.09 PM.png

It appears that if I turn off “ASIO Guard” and shove my buffer way way up, I can record without any problems(ish), so for all those interested/following I’ll keep trying different approaches and see if there’s anything more time-sensitive in terms of workarounds. I still get the CPU spike but at least I can record Audio back into Cubase…

Not a clue as to the message - however, are you sure it’s a CPU spike issue in general. Quite a few plug-ins that can do tempo-sync to not work well with tempo changes. In my music, I use tempo changes extensively, like I mean, every eighth note sometimes. I never see a CPU consequence for this, but I do stay away from delays, etc., that are synced to host tempo.

Well I’m using a whole bunch of VST’s like mulitple instances of Kontakt, VE Pro, Alchemy, Omnisphere, etc. and basically ALL of them are tempo synced. It’s been a problem for ages and instead of going through and turning off tempo sync in every instance of Kontakt I was hoping for a more “universal” (probably the wrong term) fix.

And I’m pretty certain it’s a CPU spike as the only thing that jumps like crazy is the “real-time peak” meter in the VST performance window. Unless I don’t have a proper grasp on that window, but I think that’s the case, yes? The blue bar below the “average load” green bar, if you will.

Turn off (Warn on Processing Overloads) in the preferences.

Unfortunately Peakae it’s already off…

Ok, that’s strange.

The thing to be careful of is delay-type processing. An LFO can respond to a tempo change without breaking a sweat, for example. It just has to speed up or slow down. But delays frequently have problems with tempo changes - probably some other similar types of processing as well. If this is the problem, then just saying “turn off tempo sync for Kontakt” isn’t a solution. It is the effects within a Kontakt instrument (just to name one example) that may be the culprit.

See if you can force the problem to happen with just one instrument playing. If so, go through the effects one by one looking for tempo-synced delay or similar. Turn off tempo sync (or just disable the effect) and see if the problem disappears. That’s how I would approach this challenge, in any case.

This week’s Kontact 5.5 patch has apparently fixed this tempo change/cpu spike issue.