Record Enable on recently selected track "sticks"

Hey guys,

I have a problem that I’m trying to work through and its really starting to affect the workflow. From time to time, I’m not sure why, tracks stay record enabled even after I click on and select another track. I have “auto record enable selected track” selected in my preferences, and this should, in theory normally remove the record enable when another track is selected but sometimes, and I can’t figure out why, I’ll be recording what I think is a trumpet part and I start hearing strings and, lo and behold the string track, which I had just been on, and switched off of, is still record enabled - despite my having switched tracks to the trumpet.

Also, does the record enable follows track selection also apply to parts? Or is there a way to auto select tracks when you select parts?

Best

Hi,

No, until you don’t enable the Preferences > Editing > Track Selection Follows Event Selection option.

Hello,
I’m having the exact same issue of the OP.
Does anyone know how to solve the issue he really well described ?
Thanks !

Hi,

This happens, if you are using any kind of Remote Device (Mackie Control, or MIDI Remote, or…) and there is a MIDI loopback.

Do you use any Remote Device, please?

I have a midi remote (behringer faders) but I don’t understand what the loopback is exactly.

Hi,

That means, that the input of the hardware is going to be sent to the output. So Cubase changes the Record Enable state. Sends the information to the hardware. The hardware receives the information and sends the information of the state change back to Cubase. So Cubase changes the state again (back). Therefore it looks, like the state doesn’t change.

I’m still not quite sure how to solve this as it happens intermittently. If what you’re describing is what the problem is, shouldn’t it happen all the time? What, other than not using midi faders, would be the solution?

Hi,

I didn’t know this.

Then you are right. Do you have a chance to involve any MIDI Monitor to be able to observe what happened, once the issue appear again?

Essentially, the record state of tracks “sticks” but not all the time. Do you think it may have something to do with double clicking on multiple parts and editing in the key editor with record enabled/disabled in the edit window, as I do that quite often.

Hi, if you have Preferences-> Editing->Track Selection Follows Event Selection enables, as Martin wrote earlier, and at the same time you have Preferences->Editing->Project & MixConsole->Enable Record on Selected MIDI/Audio track when you select two or more events from different tracks, these tracks will get armed for record.

1 Like

Yeah, that makes sense. The issue is that when I exit out and then select another track in the arrange window, the previously selected tracks stay record enabled… Normal behavior should be that they get un-record enabled when I switch tracks…but sometimes they stick. I’ll try to be more aware of when it happens so that I might replicate it, but I generally don’t notice until I’m recording a piano line and hear trumpets playing unison! (Or something of that nature)

I’m using a korg nano control. Is that a remote device?

Hi,

Yes, you can use it with the MIDI Remote.

Ok so do you know what can I do to solve this issue?

I’ve read the post but I’m not quite sure hat to do…

FYI:

  • Like BoZe, It does happen intermittenly.
  • again, I do have a Remote device (Korg nanoKontrol)

Many thanks :pray: