Record in Editor activated– not saved over quit/relaunch of project

If a Key Editor whose Record in Editor button is enabled does not have focus when Cubase quits, its Record Enable button’s state is disabled when the project is reopened.

In other cases the state of the button is saved, e,g., if the window is frontmost when Cubase is closed.

It does not matter which track is selected, nor do the states of “Editor Content Follows Event Selection” or “Esit/Solo in MDID Editors Follow focus”

Simply put, If the Key Editor window is frontmost, the setting is saved, and if it’s not, the sequencer reopens with Record in Editor disabled for that window.

Repro
New project, new midi track, new midi part
Open midi part in windowed editor
activate Record in Editor if it is not activated
Bring Project Window to front without closing Key Edit
Save, quit.
Launch Cubase, Reopen project

Record in Editor is disabled

+1 Reproduced here

The workaround is trivial, use the key command ‘Record in Editor’ when this happens.

Thanks, Steve – that’s actually what I’ve been doing. I set it up so when I hit my mouse-wheel button it engages “record in editor”. It’s become my most used key command now.

Problem solved. :wink: But let’s see what they say at the top…

I fixed that for you ^^^ I don’t want the developers to think it is actually solved. :laughing:

That coming from someone who thinks PC Slaves is somehow different than non P.C. :stuck_out_tongue:

Yup.

Is it normal that those tracks that are “record enabled” when I save the project, are not “record enabled” anymore when I reopen it?
I get this behavior both on Cubase 10.0.60 and 10.5.12.
I’m probably part of a minority of people that don’t have the option “Enable Record on selected MIDI/Audio track” and because of this, I have to rearm every track every time that I reopen the project, which is extremely time consuming. If this is normal, can you please add it as a new feature?

Thank you for your work

Anyone?

I wonder if this is related to the editor Window Workspace screen size/position settings not being saved either?