Record In Editor Preference

Sadly, I need to put in a feature request to bring back a function that worked perfectly in all versions of Cubase up to Cubase 9.0, so here it goes…

Please create a preference to have “record in editor” in the Key Editor remain ON permanently. As it is now, “record in editor” turns itself off when the Key Editor is left open and in the background at save & quit.

This is problematic to the few of us who use the Key Editor on a secondary display and return to project hoping to jump back into MIDI recording/editing only to find that any recording we do creates a separate region on top of the selected region.


Thanks, c2d :slight_smile:

+1 Please!!!



Hmmm… this seems like a bug, really.

New project, new midi track, new midi part
Open midi part in windowed editor
activate Record in Editor
Bring Project Window to front without closing Key Edit
Save, quit.
Launch Cubase, Reopen project

Record in Editor is not activated

The reason I call it a bug is that if the editor is closed before quitting, the setting the setting is saved.

Reported in

Hi Steve,

I appreciate you taking the time to test this. :slight_smile:

I intially reported it as a bug in the Cubase 9.5 and Cubase 10 “Issues” sections, however, I was told by tech support it’s suppose to do that and to submit a Feature Request — hence my reluctancy in the first post of this thread. I, too, believe it’s a bug as well as a pointless feature to even have. :frowning:

Post a link to those threads please.

Maybe they didn’t understand exactly what the report was about. I didn’t understand myself until I figured out that it only reproduced in a windowed editor, and not in the lower zone editor. Your request above is not specific.

That’s why step by step repros - with every minute step- are better than narratives. They restrict the reproduction sequence to only steps that lead to the error.

Please stop bumping the thread. If it lives it lives, there’s an issues thread now, and I will submit my own report to the team.

Edit: I found your original report. After reading the thread I am convinced that the issue was not understood. I’ll give it a shot.