Recorded notes appear earlier in editor than actually recorded

  • I am using Cubase 10.5 on Windows 10.
  • My controller is a Komplete Kontrol S61 connected over USB 3.
  • My audio interface is a Focusrite Scarlett 2i2 connected over USB 3.

I have inserted a VST Instrument - a VSL Synchron Piano - into Cubase. Recording straight into this track OR into a MIDI track set to the appropriate channel results in the notes appearing earlier than played in the editor, as compared with the Steinberg click track.

I have seen several old threads (from 2012 and 2015, for example) discussing various combinations of settings such as ASIO Latency Compensation, buffers, use of different system timestamps, etc. I’ve adjusted what seems like every checkbox and every numerical value every which way, yet this still occurs.

Are there later threads on this subject? This old youtube video is exactly what I’m experiencing. All I’m finding are dead threads or closed ones, claiming it was a resolved bug.

Note: not my video. There also seems to be confusion re: “gradual” drift versus a constant offset. It’s a constant offset in my case, as seen in 1:09 in this person’s video.

Thank you. I’m at wits end.

Take a look at your Preferences/Record/MIDI settings as well as MIDI settings, maybe something in there.

Also, just to be accurate, is the problem drift, or is it a stable offset? drift implies that it starts in time, and then gradually goes out of time

Also you’re not really describing where the MIDI is coming from… Is this you playing live on your Novation, or is the MIDI coming from those 3 tracks?

On the track you’re recording, it says you have the input set to your Novation. So how are you getting the 3 tracks to record onto the one?

edit

Whops i see that’s not your video

Yes, thank you. I have looked in Record/MIDI and adjusted settings there. I’m not entirely sure what each setting means (I’m unfortunately a dumb pianist, and don’t completely understand all the signal ins and outs), but I have adjusted all these values up and down in various combinations while also checking the boxes in that menu and have also done so with ASIO Latency Compensation both on and off for the track.

It’s the same result each time. The notes are consistently (stable, as you say) offset earlier than intended. It is not a gradual drift. Thank you for asking that clarifying question, though.

Have you ever tried to record a midi track when you only hear the Cubase click? That is, if you don’t have acoustic feedback from the VSTi (your VSL piano)?
I myself also know the effect that the midi events seem to be recorded too early, especially on instruments with a longer attack phase, although I also switched on the click.
That seems to be a psychoacoustic phenomenon.
Of course, I cannot judge whether that also plays a role for you, hence the question.

Good question! I have tested this out on various instruments that have various sample start delays, as well as on a “silent” (no instrument) MIDI track with the click track serving as the only audio.

This is what the latter looks like:
image

Before I switched over to Cubase, I used Reaper and didn’t have any issue with timing on any instruments, other than the known “laggy” ones (for example, Cinematic Studio Strings legato instruments).

Other than this issue, I far (far) prefer Cubase.

How many milliseconds of delay do you have on average? This cannot be seen in the picture

can you run through your exact signal chain in point form?

Also, do you have any high latency plugins? It’s possible plugin isn’t reporting latency correctly and Cubase is over compensating? I’m not sure.