Recording a drum track doesn't work as expected

Just tried to make a drum track with classic machines. I began with a kick drum by drawing notes in the editor. Then I wanted to add hihats, open and closed, to that track by recording them using the drumpads.

They were recorded, but when I looked at the track, only the hihats were visible. Cubasis made a second hihats track on top of the kick track instead of placing the hihats onto the drum track with the kick drum. Of course they were all played together but I can swipe the hihats track to the side because they are seperate. :open_mouth:

Is this a bug or a feature ? And is it possible to avoid that behaviour ? Or can I merge both tracks somehow ? I couldn’t find something about this in the manual…

Thanks for anybodys help!

Hi Glendathu,

Thank you for your message.

Recording MIDI tracks in a cycle, results in creating events per cycle.

This is intended and allows for more detailed editing and more.
To give you a short example: You could put the events to separate tracks all assigned to Classic Machines kits to quickly create multiple outputs for every drum instrument (e.g. kick drum, snare, HiHats etc.)

Of course, it is also possible to quickly merge multiple MIDI events into one event:

  • Simply tap the “Select” button in the sub menu
  • Tap and hold and move your finger to select all events you want to merge into one event
  • Tap the “Glue” button

Please give it a try!


Hi Lars,

Great, the GLUE option was just what I needed !

Thanks !!

Hi Glendathu,

Thanks for your message, glad to hear that “Glue” solved the problem… :slight_smile: