Recording a second audio track or vocals

Hi there,
I am new to the forum and it is the first time for me using DAW for recording, My Problem is that when recording a second track or using a microphone for vocals that all existing tracks are again recorded. This happens as an example when recording drums first and then piano on track 2. When I use the solo button on track two and or mute track 1… I can still hear the drums in the background. The same happens when using a microphone.

What is it that I am doing wrong.
My setup:
iPad air2
Yamaha MG 10 du
Yamaha psr 970s connected to MG10xu
Yamaha powered monitors connected to MG10xu
sennheiser mic connected to MG10xu

Thank you for helping!

Hi and welcome,

Make sure the Record Enable button is not switched on on the 1st track.

Also make sure Loopback is not enabled on your Audio Device.

Thank you Martin for your quick reply. We try this tonight.

I have tried several settings now on the MG10xu now; followed instructions in the manual etc…nothing seems to be solving my problem. It may very well be that I can not identify a setting that would eliminate loopback or I do not know where and how to eliminate it.
I have disconnected microphone and speakers when recording the second track…to only find out, it is not making a difference. Please help!