Recording at the Cubase Pro end

Hi all

Not sure how to make this work. I’m working with a client on a song using vst connect, it’s working well. However when I want to record something at my end, there is a delay between what I play and hearing it (obviously as that’s how vst connect works) Is there a way for me to record at the Cubase Pro end without the delay but still have the client hear it? Is there a facility for this?

Best Regards, Dave

haven’t had a chance to try this myself but thinking aloud ( !) - can’t you just turn off the vst connect monitor plugin that’s on the insert of the monitor channel of the control room ?

Thanks dr

Will check it out today.

Best Regards, Dave

that won’t do it - the delay is created by the CUE MIX Plugin!

well, you can use the REHEARS function on your end.

  1. click the button next to the TALKBACK button inside of the VST Connect Plugin [REHEARSE].
  2. this will disable the REMOTE DEALY!

be aware that the performer will still be able to hear anything that is send to its cue mix - but it won’t be in sync with him at all…
So the performer can listen, but might get a sync offset to himselfe (or a not “in-time performance” by you compared to him) at this point.
BUT, wehn you are done with your recordning and replay your take, the performer will hear it okay then…

So, [REHEARS] off for the recording of the performer, [REHEARSE] on for work on your side (editing, recording yourselfe,…)


the delay is created by the round loop from studio > performer > studio…but if you don’t monitor that loop (switch off the monitor plugin) then no delay…obviously you can’t monitor the feed from the performer if you do that but Dave only want the performer to hear the cue with him playing along.

The cue continues to work as normal but dave can add tracks LOCALLY without delay whilst still SENDING the cue feed to the performer.

(still haven’t tested it obviously - but i think that should work)

no vst monitor plugin = no delay LOCALLY

dr, sorry but that won’t work.

  1. you won’t hear the performer if he/she will comment on something if you disable the monitor plugin.
  2. the dealy is created by the CUE MIX Plugin. The Monitor Plugin won’t change anything. Try it yourselfe…

When you disable to Monitor Plugin, you just cut off the performer, but the remote delay (the lag inside of cubendo) will still be there!
The only way to resolve that will be the “rehease mode” - actually, that mode was designed for situations like this.


of course you won’t hear - but Dave said…

"Is there a way for me to record at the Cubase Pro end without the delay but still have the client hear it? "

nothing about hearing the performer during the LOCAL recording ?]

it’s not really true to say it’s the Cue plugin that causes the delay…there is obviously a delay because of the round trip time of the data via the internet/network…so a buffer is added…actually this is done in the performer app and the VST connect PRO/SE plugin …and delay compensation added to offset it. Why delay the Cue send…that’s the one place you can be sure of things being in time…The delay you hear in the studio is because the monitor plugin ties the mix plus performer feed together including the buffer delay. Turn this off and the delay is gone (plus the performer feed of course !).

If you do this the performer (the client) will still hear the studio feed INCLUDING the fresh recording (assuming his cue mix is set up correctly) and everything will be in time. When the Dave does the new local recording he should of course NOT use a track with vst connect pro/se in !!

I think we are taking suggesting different approaches to the problem. The answer really is for Dave to be more specific about what exactly he is trying to :slight_smile:

IMO the rehearse mode was created so that the Studio could give ‘nearly’ live feedback to the remote artist…whist rehearsing…not so that somebody in the studio could record audio without delay.

Well, it is true that we are both trying to help and suggest a possible way to get it working :slight_smile:.

So no offence here! :slight_smile: !!

But in your last sentencd you said it yourselfe: rehease mode is intended to work without the remote delay. There for almost live listening/ feedback. The performer will not be in sync if she/he plays, but in Daves call thats not a problem! So Dave could activate rehease, record himselfe, let the performer listen, all without a “lagging” remote delay inside cubendo. The moment the performer wants to record again, he just deactive rehears and keeps going…
Seems more logical for me :wink:


Hi all

Thanks for the help, the main thing was to be able to record at my end which I have now managed, just turned off the cue as dr said.

Best Regards, Dave

nice one - thanks for reporting back :slight_smile:

Great feedback from dr and basicX. Interesting use case and answers to it :grin:

:slight_smile: !

@Dave, cool to see you have it working for you now!