Recording drop out when daisy chaining FP10s

Hello - this is my first post, so go gentle on me! I’ve spent quite a bit of time in this and other forums and not found an answer to this problem that has worked for me. I recently acquired a second FP10 so that I can daisy chain 2 of them. They sync, and using the Firepod ASIO all 16 inputs are recognized. Both units appear in the control panel. However, when I record, whether it be 1 track, or 16, it drops out unexpectedly. Sometimes after 20 minutes. Sometimes after just 1 minute. Typically after 3 or 4 minutes (just before the end of a song!). I tried increasing latency in the FP10 control panel but that made no difference. The ASIO meter is very low, barely working. as is the Hard Drive meter. Nothing should be taxed to record 1 track! So I don’t think it is an issue of overloading anything. I tried swapping which unit was first in line. I also saw posts about problems daisy chaining and matching up the firmware, and got the updater from Presonus tech support. I updated the firmware (which has to be done on an XP machine), reinstalled the latest drivers - same outcome. BUT when i connect just one FP10 and record, even arming all tracks, it is stable and cruises along with no problem. I stopped the test after a hour when it was clear it was not going to stop itself. Both units tested out fine individually this way. They work great one at a time, which leads me to conclude that the computer, ASIO, firewire card, and whatnot are fine. The problem appears when I daisy chain them.

Any suggestions? I’ve seen other posts with a similar problem, but it appeared that firmware and drivers fixed their issues.

Thanks in advance -

What firewire chipset and speed?

Hi - thanks for responding. The chpiset is VIA Technologies “OHCI Compliant”. I ran a test program that someone posted on this forum and the result said the chips were compliant. Bear in mind that one FP10 works great. I ran further tests last night and I could not crash one unit. But hook up both units, and it crashes every time. I’m convinced it has to do with the two units talking to each other, or some instability in the daisy chaining process that Presonus isn’t talking about.

FIXED. I found this solution in another post, so I’m not taking the credit. The issue was not my chipset (on the approved list) or firmware (updated with program e-mailed to me by Presonus tech), or interface drivers, or my ASIO, or in the devices being daisy chained … it was simply the firewire bus driver in my PC. Here are the steps posted by another guy:

Just go to Device Manager, find your IEEE 1394 Bus host controllers, right click and select Update Driver Software…step1
2. On the next dialogue box pick “Browse my computer for driver software”
3. Now choose “Let me pick from a list of device drivers on my computer”
4. On the final screen you should see at least one 1394 driver that has “(legacy)”
at the end of the name. Select that one, hit next, and you should be ready to go

I tried this, found the “legacy” driver (appeared to be Windows generic, not VIA) and presto. I’ve run three successive tests of 30 minutes each with no drop out. 16 tracks armed. Not a glitch. What a difference! I won’t pretend to understand it, but it works.

Thanks - hope this information gets to someone else before they sink the time that I did into this problem.