Recording Drumtrack with Yamaha DTX 700

Hi all,

i connected a DTX 700 Drumset via MIDI to my Focusrite Scarlett 6i6. The Scarlett connects to iPad Air 64GB (iOS 7.06) via USB Cable / Apple USB Lightning Connector.
When the Drummer now hits any Drumpad, Cubasis plays the related Sound. Up to now everything is fine, but:
If the Drummer is playing a triplet only the first hit will sound. Also if i record the triplet there is only one MIDI note.
In short, if a pad is heat twice in a short time, the second hit is not received as MIDI Signal.
I tried the same Setup with Music Studio (which is still installed on my iPad) and have the same issue.
To add confusion now, i tried the same Scenario with Garageband and Drums XD. With these Apps everything works perfect.
I would exclude any Hardware-Issue but why are two apps running fine and two others having similar issue.
Any idea what i could do to make everything work in Cubasis? Any help is greatly appreciated!

I made some further tests and trials to fix the issue. Unfortunately they were unsuccessful :unamused:

  1. To ensure it is not a problem with my iPad, i installed Cubasis on the iPad mini of my wife which is running on iOS 7.1. Problem with the DTX was also with the iPad mini.

  2. Instead of the Scarlett 6i6 i connected the DTX Midi output to one of these USB-Midi 5pin Cables. Result was similar so the scarlett is unlikely the root cause of the problem.

  3. I made a factory reset of the DTX 700 to ensure there is no weird setting in the DTX causing the issue. As expected without improving the situation.

I am running out of ideas. Still wondering why Garageband and Drums XD process the Midi Data of the DTX correct. When i have some time, i will test the whole setup with Cubase on my Computer and see the result there.
Sad, because my intention was to use Cubasis for some draft demo recordings in our band room.
Thanks to anybody who can provide a helpful hint.


Just for the record if somebody is experiencing similar issues. I found great support in the Audeonic Forum. Here is the link to the related thread:

Looks like the issue is caused by the DTX but this workaround is providing a solution.