Recording in score editor produces only staccato notes

Repro:

  • create a midi or instrument track and load a vsti
  • record a midi part on that track
  • open it in the score editor
  • hit record again and play

-> all notes will sound staccato and will get recorded as such (e.g. as short notes)

Can anybody confirm?

Thank you

What’s the quantize length set to in the Score Editor?

I was just going over some old posts at cubase.net looking for the short note bug in score edit. I see we have corresponded before about it, parnasso…

At the time, Jan 2010, I had come back to Cubase after a long hiatus, and in trying to workaround the freeze caused by recording beyond a part’s limit, I moved the prefs and, according to my post, then created the short notes problem.

Could moving the prefs have actually created conditions for that bug, or was it actually there all along and I didn’t notice it for some reason?

@ mashedmitten:

it makes no difference what the quantize length is set to, it happens with whatever setting.

@ Steve:

Yes, I remember that we have corresponded before about it, you seem one of the few persons who use Cubase’s score editor :slight_smile:
I think that the short notes problem and the subsequent freeze when the part’s limit was reached came in 5.1, in 5.0 I think it worked ok (although I’m not sure). Then in 5.5 they fixed the short notes and the freeze but the vertical lines were still there. But if I remember correctly this whole problem had also been present sometimes in C4 or C3, was then corrected but came back. Vic France had mentioned something about this. So it seems like it comes and goes :wink:
Let’s hope they can fix it once and for all…

I was halfheartedly hoping for a workaround to that staccato notes bug… Guess I can have the score window open above a key edit window until that gets fixed. It is amusing to watch the notes animate in score as they get added in key edit, so that’s a plus, right?

High hopes you have. [insert head smashing against wall smilie here]

Just checked it and at least it’s half true: the quantize length has an impact on the recorded events, with other words, they play back in the chosen length. But while you record it, the notes sounds very short.

Thanks, O.
So if you monitor another track with the same midi input and output, and mute the track onto which you are recording is the result that what you play sounds right? In other words a temporary work-around?

A detailed post from parnasso regarding this: (the forum software is not permitting him to post here for some reason)

And the fonts problem is on both machines too? Did you fiddle with the Appearance control panel (Use LCD font smoothing when available and Turn off text smoothing for font sizes 4 and smaller.) There is also a terminal hack I used for some other thing having to do with fonts a few months ago, I’ll look for that.

I’m going to post your most recent message to the forum… I figure you are okay with that from what you said. (“of course you can…”)

Thanks for taking the time to do this, parnasso.

Steve

Just wanted to say I’m back and I can post again (thanks Steinberg) and I want to thank Steve for posting my findings.

The Oracle, thank you for your feedback! Could you please provide further information on this issue? You seem to suggest that on your system the notes do get recorded in the right length and they sound short only during recording. I have now installed C6 on 2 different systems (both Macs), have started with fresh preferences and in both cases the notes get recorded as short notes… in my findings posted above by Steve you can read that in my key editor I can clearly see that the notes are very short (albeit of random shortness). Maybe you were referring to step input mode? I’m talking about live recording.

I would be thankful for any additional feedback!

I’m talking about live recording as well and I have checked in the key editor that the events have a different length. The events “just” sound short if you play/recording them,but the result is accordingly to the chosen resolution. Nevertheless, even if there is a work around, this is not acceptable and has to be fixed.
Were you able to exchange the q-length and it had no effect?

parnasso, any joy with this?

Thanks for the report. We will look into it. (28072)

I also had problems when recording in score editor : I could hear only short notes. In Cubase 5.5 this problem didn’t exist.

JJL

Thanks for your response. Maybe I’m misunderstanding what you’re saying but I tried changing the quantize lenght in all available forms (normal quantize, length quantize and display quantize in the score settings dialog) and the notes are always recorded short as I can see in the key editor, regardless of any setting. The “shortness” varies a little bit, not all notes are equally short but none is more than around 80 ticks with the majority being less (at PPQ Base = 480).
I really don’t understand what influence any quantize setting should have on the actual lenght of the recorded note events, only the displayed note value in the score will be determined by the display quantize settings. In 5.5 I can record any note length regardless of any quantize settings.

Thank you for looking into it, I hope you can resolve it soon!

I think he’s referring to the auto-quantize function whose button is in the transport.