Recording issues from Yamaha P90 - fading/missing sound

Hi community!

I have Yamaha P90 and Steinberg UR22mkii interface, and my use case is to play and record music from the keyboard using Cubase AI9.
Got everything setup, incoming signal from the keyboard is in Cubase allright, now my problem is that once I record a track, the sound of my e-piano is somehow cut on edges, as if some kind of Fade-In/Out is activated. I wonder if that’s a wrong driver use or some other setting. Could anyone suggest where to look?

Summary of setup:
Steinberg’s native driver used as ASIO driver: https://monosnap.com/file/lTCXwV9EIhh18S5SIVPLJ532C7RYH3
Input setup as follows https://monosnap.com/file/1Bp3YVNWFkzLKEyc4ZeVZlOCSK6keL
I am not using MIDI (no cable connected etc), but this is the default config in Cubase: https://monosnap.com/file/Kcd6Uvl12w2z9j1gwaFbBWEYqsJ65L
I used Piano + Voice template of Recording, but as I couldn’t get the Piano track working, I deleted it, and am using Voice track (renamed into Yamaha) to record: https://monosnap.com/file/74mBjfq6yMHFoYHF2t32FQCK7UmojM
Input and Output setup as follows: https://monosnap.com/file/jDHX8OH1wTxll4ifkEEGG9Q94Qm7gh

Thanks!

Flowchaser

Judging by the blue colored button showing in the track inspector insert section, it looks like you have a VST effect insert assigned and enabled. Disable it by clicking on that blue button. Or click on the insert section for a dropdown menu section to see what is assigned. Disable or remove it (them) and listen again.

Also, judging by the green button I see, you have an equalizer enabled too. Click on that button to disable it too.

Regards :sunglasses:

Thanks Prock, it helped!