Recording latency with seemingly low lag

I’ve been using Focusrite Scarlet 6i6 2nd gen as my interface for a long time but recently upgraded to a new PC. With my new PC which is quite powerful: i7, 64GB and a good SSD I’ve been experiencing quite a bit of lag while recording and can’t figure out what is going on.

I am experiencing the lag with most of the VST amps I play through (mostly Neural DSP) and also with MIDI input with VST instruments even if I seemingly should have around 3ms of delay which should not be noticeable. I can play through Guitar Rig when I have a project with almost nothing in it and go to very small buffer sizes like 64 and get my delay to around 1,5ms. With the Neural DSP plugins I can have an otherwise empty project with 32 buffer size, have around 2ms of latency but still when playing the delay is there. If I use the ‘Constrain Delay Compensation’ it will deactivate the Neural DSP plugins but I know that people use them live with worse computers with no issues. I’ve tried to otherwise optimize the Windows and other settings to get the best performance possible and I am not using a USB Hub. I am using ASIO drivers

I didn’t have such issues with my old PC which had much worse specs than my current one.

Any ideas where the latency might be coming from?

Hi,

Make sure, there is no plug-in at the output or monitor bus, please.

Thanks Martin
I have no plugins on the master bus, I can have barely any plugins on the project and the behavior is still as described

Windows Ultimate power management or Steinberg audio power scheme enabled?

Try going to “Studio–>Studio Setup” from the menu and then clicking on “Audio System” on the top left, then drop down the advanced options and then disabling “Activate ASIO Audio-Guard.”

Not sure that this should matter but that setting has caused some issues and it might be affecting the Neural DSP plugin.

Any news on this topic? Im having the exact same problem here! :frowning:

If you have plugins that are set to an aggressive linear phase then it could be that

Also what sample rate are you using?

Are you using Asio 4 all or native drivers? Have you updated the audio drivers & made sure cubase is using the correct Audio driver?