Recording MIDI to audio - real time cracks are recorded too

Yes you did… :slight_smile:

Good man :stuck_out_tongue:

Search this forum or google for ‘internal summing - Cubase.’

You can record anything from a midi track in Cubase in real time without rendering/ mix down. This involves creating additional ‘unconnected’ (unconnected as far as your available ASIO outputs are concerned) outputs in the VST Connection. You then route the output of a VSTi to and audio track, monitor the track and hit record in the transport. If you can host the instruments you want, why not simplify and do it that way? Just use the VST Rack.

http://www.youtube.com/watch?v=5fw-gMEXS34&feature=plcp&context=C24f47UDOEgsToPDskJbfmP0BO_edTq9FLfSg3If

Check out about 1:50 into the video.

Como

I know, but with software instruments this should never be done, my original question was precisely about the fact that this internal mixing/recording (“summing” as you call it), even though it can be entirely software and internal to Cubase and not involve the ASIO card at all, it is still dependent (apparently) on the ASIO buffer size.

That’s because it happens in real time and so it uses Cubase’s real time audio pipeline, which is based on the ASIO buffer size at every step of the pipeline. The fact that the ASIO card happens not to be used in this particular path of the pipeline does not change the pipeline itself.

Here is what I was doing:

(instead of a Group or FX track you can equivalently use a ghost output created in the VST connections window)

If the instrument generating sound from MIDI is hardware, that’s the only way possible.

But if it’s software, this method should NEVER be used (I think the Steinberg video you link to should have said that), since it will randomly introduce cracks and pops completely unecessarily.

You could temporarily increase the ASIO buffer setting of Cubase every time you record and change it back when you’re done, but it’s very slow and you would be using the wrong tool for the job, and if you are recording 15 minutes of MIDI, you would still have to actually wait 15 minutes every time, which is entirely pointless and unnecessary if everything is software and could be done in a fast, guaranteed cracks-free, bit-accurate non-real time way with an audio mixdown.

I’ll ask on the Bidule and VSL forums and post the answers here if I find anything useful.

seb from Plogue found the problem, it occurs when BiduleVST is notifying VE Pro that it’s running “offline”/faster than realtime during audio mixdown. It will be corrected in the next version of Bidule.

Mixdown should then work correctly when VE Pro is hosted in Bidule.

Nice :slight_smile:

This method is exactly for software … and I never get any “cracks or pops” when I use it.

You seem to have very strong opinions for a new member. Best of luck in finding the solution that fits your preconceptions.

Como

I shouldn’t have said “never” in such final way. Sorry if I said anything arrogant.

I am willing to change my mind, but what is the advantage of this method?

I have to agree, file/export/audio is the way to go with this…

it shouldn’t be that hard to recognise that your original method is somewhat similar to recording the output to an external tape (where the tape is just another track in cubase) whatever goes to that tape in real-time is what is recorded, click, pops and notes.

export and make sure real-time is unchecked.

along these lines but a much simpler problem:

As backgound I’ve done heaps of purely audio mixdowns in the past and one mixdown that included a preset Groove Agent 1 track to which i’d added a few beats of my own using midi keyboard through GA1. The mixdown was no problem and all tracks came down through the mix.

But now I have a project that consists of a few audio tracks and a few midi tracks recorded through VST instruments (Halion and a Groove agent1 track). when I mixdown I get a file that contains only the audio tracks and none of the midi tracks. The midi tracks were recorded through VST instruments using a midi keyboard.


I haven’t found anything in the manual to help me with this. there isn’t even an index entry for mixdown of tracks of any kind that i can see though as i say i’ve managed many previously with no problem. what am i missing? (all answers gratefully accepted)