Recording MIDI with the sound of my keyboard

Hi everyone,
Probably there will be a similar post on the forum, but I was looking for it and I could not find something concerning Cubase LE, so I open a new one. I have a big problem concerning the recording using midi with sounds of my keyboard. The keyboard is a Roland G800, not listed in the Midi Device panel, but I was told it could work the same if I link the midi IN of the audio card (Komplete Audio 6) to the Midi OUT of the keyboard and vice versa.
I did the connection, the keyboard is recognized, I can record a midi track, together with the audio track from the keyboard, but when I play it (muting the audio track) I only can hear a very bad piano sound, not the Hammond I wanted. What is that I do wrong? I would like to be able to edit the midi, for example for correcting a little mistake instead of recording all again and again. Please help! :open_mouth:
PS: I am a little too much newbie with Cubase, so please don’t go to hard and technical with explanations :wink:

Thanks for the help! :smiley:

Hi and welcome,

Where is your MIDI track routed to? Is it routed to the G800?

If you want to hear the sound from the G800, you need an Audio track. You don’t need to record the audio data until it’s perfect. Just enable Monitor button (speaker). This Monitor has to be always switched On, on the Audio track.

Hi Martin, thanks for the answer. I connected the MIDI cable IN from the G800 to the MIDI OUT in the Komplete Audio 6 and the MIDI OUT from the G800 of the keyboard in the MIDI IN of the audio card. Then I made two tracks, one Audio track and a Midi track both of them recording at the same time. If I understood correctly, you are telling me I can record the midi and leave the Audio track with monitor on, without recording it? If this is enough, god bless Martin Jirsak! :smiley:


You have to Record it at the end only, when you are redy to export.