Recording Midi

I am attempting to record Midi and/or VST instruments using CueBase and I cannot get it to work. First let me say, that this concept is completely foreign to me and my electronic and midi experience has been dragging loops into a timeline using GarageBand, so I probably need a good intro about setting everything up in CueBase.

First question, do I need an external “controller” to record midi using CueBase? I was under the impression that the VST instruments and Midi sounds were all internal to CueBase.

If the answer is yes, then I will get one. If the answer is no, I will trace my steps here and this is from a few tutorials I discovered on YouTube:

Add instrument track, pick the instrument, in this case a drum pad, which sounds and feels fantastic. However, when I click and enable record and start playing the pad, nothing gets recorded.

I am using the Firepod 10 for my interface.

My guess is, this is some simple routing or setup issue.

Any help would be greatly appreciated!

You don’t need an external hardware controller. But you can use it, and it’s better to use it, very often.

VST Instrument are sound generators. It doesn’t matter, which way do you choose for get MIDI data (notes). If you will record it by MIDI keyboard, MIDI pads, computer keyboard, program it in the Keys Editor or List Editor, use Beat Designer, etc. VST Instruments are integrated in the Cubase.

Lots of instruments can’t send MIDI data from the instrument to the track. So this way doesn’t work very often. Right-click in the Transport bar, and activate Virtual Keyboard. Now, you can use your computer keyboard, or mouse, to trigger (and record) MIDI notes.

Nice vid about midi recording in Cubase even though it applies to Cubase 7

http://www.youtube.com/watch?v=YzWLtTkzCtg

I followed that video step by step and when it got to the part to choose “midi Inserts” I cannot, because this button is not available. I think there must be something not routed our setup correctly.

Martin, I can pull up a keyboard I can select record on the track and play the keyboard, but it does not record anything on the track.

Can you check your preferences? Check MIDI > MIDI Filter, please. Is there something checked?

Everything was checked (see screen shot). I unchecked everything and record will still not work. Is there not SOME documentation somewhere that walks you through all of these settings and what you need to do to make this simple for dummies like me who don’t understand the zillion and a half options?

Thanks!
Screen Shot 2013-03-11 at 8.45.06 PM.png

Ok, I am beginning to believe that I have a faulty version of this software. I have tried everything in documentation, I have watched multiple how to videos, all of which walk me through the same basic steps I’ve been doing, and each time I get the same result! Nothing will record. I can even open one of the sample projects that has the composer window and I can add notes all over the staff and this will play back just fine. However, when I try to manually record using a VST instrument and/or Midi it will not work! I have been through every preference imaginable in the setup menu, checking, unchecking, and then back to default(which should work fine) and nothing works. I get no activity on my track bar, no indication of notes or sounds being recorded and when I hit stop, the transport area goes blank. Please see the screen shot I have attached that shows my system armed and ready to record. Please help! I am ready to ask for a refund for this system based on this one glitch. I truly hope it is operator error of the worst kind and can be corrected. Is there anyway Stienberg support will accept my phone call to walk me through this?
Screen Shot 2013-03-11 at 10.21.18 PM.jpg

Do you have/use an external MIDI device when recording?

I doubt that you have a “faulty version” of Cubase. It’s more likely some settings or swithes, it usually is.

Did you uncheck the filter checkboxes (from the previous screen shot)?

On that last screen shot (with Groove Agent ONE) are you recording by click with mouse on the pads?

Are the MIDI events showing as being received? (I am not referring to the sound bars peaking, but MIDI data.)

Unless you already understand it, MIDI is only activity EVENTS. Only an instrument receiving MIDI Events generates audio, based on the events received.

I have a vague understanding of this, but I don’t think that has anything to do with why this is not working, because I have done everything as instructed.
Thanks!

Does anyone here know if Steinberg offers phone technical support in America, and if so, do they charge for this service if you have a registered piece of their software?

Thanks,

I suppose, this is somewhere in settings. Sometimes, it’s faster to trash preferences, and get factory settings.

No, you can simply draw in MIDI notes. There’s a virtual controller as well that allows you to use your keyboard

I’m not sure how you’re playing the pad if you don’t already own a controller. I guess you’re just clicking it with your mouse? I see that the Firepod 10 has a midi in and out bus. I would recommend buying a MIDI controller and popping it into the back of your interface. Make sure you have the proper drivers installed from Presonus for your Firepod. In Cubase, go to Devices > Device Setup > MIDI > MIDI Port Setup and designate your Firepod as your MIDI port. When you create a virtual instrument track, make the input the Firepod port that you just set up.

Boom. Done

I hope this helps man


By the way…It’s Cubase (Not CueBase)

How would you go about “trashing preferences” and getting “factory settings.” I’m pretty sure you are asking me to choose “default” on all settings, or should I be deleting a specific file somewhere in the application’s file structure? This used to be a common trick used when I worked in software tech support years ago, we’d rename the config file (in case it didn’t work) and then delete it and restart. Sometimes, in other applications, like Dreamweaver or Contribute (totally unrelated to this) that I use at work, we have to delete out certain cache files when the apps start doing weird things.
Thanks

Can’t record via pads on a VSTi. Virtual Keyboard or entering Data in an editor are the only ways if no external controller. PM me if you want to do a Team Viewer session to see how it’s done.

Indeed it is!

Thanks! I missed this before I wrote the “novel” response to another respondent! I can’t get it to work on the virtual keyboard either. Could it be because I’m using the mouse instead of the Mac’s keyboard.

Don’t know, VK works here. Could be the VSTi. Quickest way would be to do a Team Viewer session to suss the issue. If you want, download it and send me the creds via PM. Have Cubase open and the equivalent of notebook open (text app).

Thanks! Who is VK? I would be happy to do a Team Viewer session but I’m not at my studio during the day, except on weekends. I’m also not sure what a Team Viewer session is or how to join and/or setup one. What are you asking me to download and what are “creds?” When you say “suss” I am assuming you mean assess or determine what the primary issue is.

VK= Virt. Keyboard. Team Viewer is an app to share screens. Don’t have to install, just run it. Creds are the user and password to start the session. Suss means to find the issue. We can set a time for tonight or this weekend, let me know.