Recording pre-roll


I’ve noticed a strange issue in 8.5 - I’m not sure if anyone has seen this before.

Sometimes when I’m recording with preroll on, cubase records this rather than punching in post preroll.
It means I have a blank recorded section at the start of my clip, which is the same duration as my pre-roll count in. Any ideas?

The workaround is to use the range tool and crop the clip to what it should be. It works but it’s a pain.

Its not obvious until you duplicate the part.



Did you record Audio or MIDI Part? You wrote “sometimes”… Is it based on some condition or does it feel like random?

Hi Martin,

it was both audio and midi - I’m trying to recreate the conditions at the moment as I only started noticing it recently. It sometimes happens with the post roll too - it’s really strange. Hasn’t happened before 8.5. I’m wondering if there is a preference somewhere which might be causing this behaviour?



I could imagine something in the preferences just for the MIDI recording: Preferences > Record > MIDI > Snap MIDI Parts to Bars.

I don’t use pre roll, I just set the parameters for the punch in spot (and punch out, if using it) and set the cursor a few bars before hand. When punch in is activated, just press play, and it will automatically record when the cursor hits the left marker/punch in spot. I made the shortcuts for activating punch in/out as keys i/o in my keyboard. Or is that default? I don’t remember, but I made shortcuts for my frequently used functions.


You have Cubase 7.5 in your sign. But there is a new Punch In/Out mechanism since Cubase 8. There are dedicated Punch In/Out Markers. They are in sync with the left and right locators by default, but you can also decouple them.

I’ve been running 8 since it came out, I just haven’t been here in a while. I don’t have any issues, I’m just wondering what pre roll is being recorded, when, if you set the markers left and right, and have punch in/out active, it will only record the part within the markers. Pre roll is as long as you want, just drag the cursor back and let it play.