Reference Level in Control Room NOT working with Key Command.

Reference Level in Control Room Issue.

Activating the reference level in Cubase 9.5 works fine when using left mouse click.
Activating the reference level does not work with Key Command (Key Comand Name: Reference Level On/OFF).

Issue: When using a key command (rather than a left mouse click) to activate the Reference Level, the button turns green, however, the button does NOT change the control room level as it should.

Recreate Working State:

1.) Set Control Room Level to -3
2.) Alt-Click Button for Reference Level to set it to -3
3.) Change Control Room Level to 0
4.) Click Reference Level Button
5.) Control Room Level Changes to -3

Recreate the Issue:

1-3.) Follow steps 1-3 as above
4.) Do not click reference level with mouse but use key command. (Key Comand Name: Reference Level On/OFF).
5.) The green button activates
6.) However: Control Room level does not revert to -3 as it should.

Operating System Windows 10 / Creator Fall.



I’m not sure if this KeyCommand should turn the knob to the Reference value. Please read the manual, what does it say about this function?

I have the same set up as avviano, but this is working correctly.

I assigned a key to that command, and it toggled between ref and the previous value, with the corresponding lighting of the button.

Barring user error, maybe there a corrupt prefs issue?

I read the manual again Martin, although the command “Reference Level On/Off” is pretty self-explanatory.

What is strange: As I have stated before, when I mouse click on the reference button it does what it should and what Steve seemingly is experiencing as well, when using a key command. It turns green and toogles between level and reference level.

However, when I use a key command it activates the Reference level (turns the green light on), but instead of switching from level to the previously stored reference level, it actually writes the existing level into the reference level. If my reference level was previously set to -3 (double checked in preference>VST-Preferences>Reference Level) and my current level is 0, then instead of toggling from 0 to -3, it activates and sets it to 0.

It looks as if the key command “Reference Level On/Off” actually initiates the command “store new reference level”. I have also tried using a different key command, to avoid some potential conflict. But I keep on getting the same behavior.

Hence I still have to assume it is a bug.

Just solved the issue.

Since the ALT modifier key is used by Cubase internally in its software engine to set the Reference Level, any key command assigned to “Reference Level On/Off” using the ALT modifier within its shortcut string will not work! Instead of toggling the reference level on/off, it will store the existing level as reference level and activate (green).

Solution: Do NOT use ALT as part of your key command string assigned to “Reference Level On/Off”. This will make sure the “Reference Level On/Off” command will behave as it should.

Conclusion: Since the ALT modifier is used in so many key commands, I would still define this unfortunate behavior as a bug, although it arguably is a bit of a “grey area” one. Using a modifier other than ALT in Cubase’s internal engine to set the reference level would be advised. If that’s not possible, Cubase should block USER from entering ALT as an option for key command assignments for the command “Reference Level On/Off”.

Nice sleuthing, avviano. The [alt]/[opt] key is never a command by itself, just a modifier, so I agree, imo this is a bug:
A key command for “Reference Level On/Off” containing [alt] modifier key unexpectedly sets the Reference Level value.


  1. Assign a key command that uses an [alt] modifier to “Reference Level On/Off”
  2. Set a Reference Level in the Control Room.
  3. Adjust the control room volume to a different value
  4. Invoke “Reference Level On/Off” using the key command
  5. A new ref level is set unexpectedly.

Reported, CAN-13630

Thanks Steve for taking the time to read the post and finishing off the bug report. Nice to see how concise you boiled down the report into one sentence!