Registration issue with Cubase13

image
Greetings all,
I was bench testing the free version of Cubase13 to see if it was happy on my system. Everything went well and I of course decided to buy a license for it. I went on the portal for cubase thinking I can just pop in the key and everything would be cool. But doesn’t seem to work. On the portal before any keys are entered, it says it is already authorized. I am thinking thats just for the duration of the free version which I think expires around 6/8/24. Do I have to uninstall/reinstall?

The error message has nothing to do with Cubase. You have installed some third-party plugins that use iLok authorization, and the iLok software on your machine is not up-to-date. What happens if you just click OK?

Cubase runs very well despite the error. I thought the same as you. went on the web link provided and got the latest/greatest. But I can’t really clear out this error.

Have you rebooted your machine?
If yes, and the problem persists, and if you are on Windows, go to these locations and check whether there are any plugins you don’t use:
C:\Program Files\Common Files\VST3
C:\Program Files\VstPlugins
C:\Program Files\Steinberg\VstPlugins
C:\Program Files (x86)\VstPlugins
C:\Program Files (x86)\Steinberg\VstPlugins

If you encounter some unknown plugins, move the corresponding files to trash and try to restart Cubase.

Thank you Valsolim ! You are exactly correct… little bit of dead wood in the old VST area… Did some clean up and PRESTO, loads error free now.

Thanks again. joe

1 Like