Registration issue with Vertigo Strings and library manager

I purchased CI Vertigo Strings. Followed the download process using the Download Assistant. When I click “Open” button, the Library Manager doesn’t launch to register the library. Some steps I’ve tried:

  1. Verified that vtsound file was in the default download location
  2. Installed latest Download Assistant (1.15) and retried registration process
  3. Activated license in eLicenser app. No issue. Repeated download and Open process. Library Manager still doesn’t start
  4. Launch Library Manager so that it was running when clicking the Open button for Vertigo Strings in Download Assistant. Still no registration.

While searching the forum for help, I found similar issues for other CI sound libraries and noted that Alto Glockenspiel had a v2 update. Downloaded that library file in the Download Assistant and when I click on Open, Library Manager ran and registered the new version of that sound library.

To me, it seems like Library Manager doesn’t acknowledge the Vertigo Strings registration request from Download Assistant during the API call, although I’m only guessing that the name of the product is passed from DA to LM. Any ideas?


Did you try double clicking the vstsound file itself? It should launch the Library Manager and hopefully register the vstsound.


unfortunately this was an issue with the Steinberg Download Assistant. We have already fixed it.

BTW, misohoza has already mentioned a working workaround

Hello Misohoza and Frank,

Just got off the phone with Jeff from Yamaha support who told me the same thing. Yep, double-clicking on the vtsound file opens the Library Manager and registers the sound. Makes a lot of sense for content products but I was stuck on the support documents that guide to 1) download with Download Assistant, 2) Click OPEN, 3) Library Manager launches and registers, which has and does work for other products.

Thanks a lot for your responses. Steinberg has a great user community.

Best Regards,