"Regularly" intermittent dongle detection

I’m running Cubase Pro 11 in Win10 and I’m facing some USB-eLicenser problems:
Cubase always starts regularly but then, as soon as I open a project which is using Groove Agent SE, the eLicenser detection gets stuck in loading GA and I’m forced to kill the Cubase process, unplug/re-plug the dongle, start Cubase again, load the project again. This is the only “working” workaround I was able to find.
Mostly every time the second attempt is successful, as if it was somehow needed.

Searching the forum I’ve learned many users have problems with the communication between eLCC and the dongles. Somewhere, months ago, I found an advice by a moderator who suggested to try installing the latest 6.11 release of eLCC, which I did; the situation seemed to get better compared with the previous one (so I did not upgrade any more), but the above problem still remains.

Any advice on how to solve it?

  1. Run the CURRENT eLCC. When I update the LCC here I always run the installer and DELETE the old one here form the installer. It may or may not have that option on PC

  2. Open the Steinberg Download Assistant and go to Cubase installer for C11 update or C11 and run the GA Installer again.

  3. IF you have an OLD e Licensor, buy a new one

  4. Try another USB port. Make sure your power settings on that port are set to not shut off as well in Windows

shanabit meant to say, ‘buy a new dongle’. I would start there.

1 Like

YES, that is what Shane meant :grinning:

1 Like

Thanks for your replies.
I understand the meaning of the “buy a new dongle” advices, but I already own two dongles and I’ve no intention to spend more money in buying others. Knowing, moreover, that the dongles are now starting to leave the scene and that I could easily find myself, in the event of an update to Cubase 12, with three redundant useless pieces of hardware.

I know my dongles are “old” but they are not broken; they both work perfectly as usual, as soon as I connect them to my previous PC, where the old Cubase is still installed. They are only apparently affected, like their peers, by some (firmware?) problem which makes them unable to communicate flawlessly with many current motherboards, despite those motherboards being obviously compatible with the older USB standards. Or maybe the problems lie in the eLCC software, who knows. Moreover, when last year I bought my upgrade to Cubase 11 there was no notice whatsoever, in Steinberg’s site, about the need of a new dongle; the site said that if you already had an USB-eLicenser you could buy only the license upgrade. And, as far as I know, Steinberg is going to stop producing and selling (and supporting) the dongles, so that anyone wanting to keep using any “old” music software will have necessarily to keep using the dongles they already possess.

Anyway, I did NOT open this thread to complain or discuss about dongles, Steinberg’s dongle/license policy and so on. That’s quite pointless, actually.

I just wanted to share with other users, given the known USB problems, any advices or experiences about how to reduce those problems as much as possible (with no purchases).

I think it might be worth updating to the latest Elicenser version. Especially if you have the installer for the version that seemed to work better - so you can uninstall and go back.

Which dongle is it? https://helpcenter.steinberg.de/hc/en-us/articles/115001652690

image

If the OP has no intention on getting a CURRENT DONGLE then he needs to just move on and get C12. Wait, that’s more expensive than the dongle.

I gave 4 suggestions. Hope you get it sorted. My dongle is Gen 4 BTW and Ive had Cubase here since SX2

I think it’s the second from the left.
I noticed that sometimes, when a new eLCC version is released, the release notes report
“Improving communication between protected applications and eLicenser system”.
Such a sentence, while indirectly confirming the… suitability of communication improvements, may be a good reason for trying an update. Sadly, however, that particular notice hasn’t been appearing since release 6.12.8.1296 (October 2021); all subsequent updates, apparently, only brought changes to the license database.

Am I wrong in perceiving a slight… irony? :slightly_smiling_face:
I understand and accept that, but I think there is quite a difference between spending money in buying a new version of the software (with user-oriented new/improved features related to actual music creation) and spending money in buying something which is useful only to the software producer and does not bring to the user any kind of novelty or advantage (apart from the… possibility to use with hopefully less inconveniences a program already purchased and paid for).

Anyway, as I said, I mainly wanted to know whether other users are having dongle issues like mine, with Cubase that loads fine (first “call” to the dongle?) and then GA inside a cpr unable to find its license (second call?) and both loading well after killing Cubase.exe, unplugging and re-plugging the dongle and starting all over again.
I’d like to know if this is happening only to me; and, in case something similar happens also to others, I wonder if they found some way/workaround to improve the situation, if not to solve it. And I guess this forum is maybe the best place where to search for this kind of information.

  1. Run the CURRENT eLCC. When I update the LCC here I always run the installer and DELETE the old one here form the installer. It may or may not have that option on PC

  2. Open the Steinberg Download Assistant and go to Cubase installer for C11 update or C11 and run the GA Installer again.

  3. Try another USB port. Make sure your power settings on that port are set to not shut off as well in Windows
    [/quote]

  4. Are you using the last update of C11???

*Have you tried these options yet?

*GA SE is not a licensed app as it is included in C11 to my knowledge. Thats why I suggested re installing it so you have the current one

Have you tried starting Cubase with new prefs? Move the old prefs to another location and boot Cubase and see if you have the SAME issue. If not we can rule out the DONGLE itself if the error goes away.

Im using C11 here with the current eLCC App BTW. no issues. No GA SE errors.

You have to TRY something there.

From my viewpoint your GA need reinstalled. Current C11 installed, Prefs deleted so you have new ones. Current license app installed.

Hope you get it going there.

I’m afraid I have actually tried all of them, in the past months.
I have the latest C11 update and also the latest GA SE and Halion Sonic SE.
I, too, thought that those plugins where “included” in Cubase also from a… dongle point of view, but they seem to check for the dongle every time they get loaded.
When, once inside Cubase, I open a cpr which needs GA, after a while I get an error from GA itself not being able to find its own license, which probably is included in (subordinate to) the Cubase one but needs to be checked anyway, maybe because the inclusion is of a commercial nature only. Something similar happens if the project I try to load uses HS. Moreover, if I keep eLCC window open during the operation (one of the many attempts I made while trying to spot the problem) I see the the dongle gets… consulted many and many times while a project file is loading, depending on the kind of plugins (free or licensed ones) which have to be loaded.
Everything works fine if I open any project using just free plugins.

The strange thing is that Cubase itself always (mostly) loads fine; which proves that it correctly detects the dongle and the license. But just a few seconds later, when the very same dongle has to be checked again to load GA or HS, it seems to have… disappeared. Later, when I have killed Cubase.exe and unplugged/re-plugged the dongle and I repeat the exact same sequence, the project gets loaded with no delays.
I’d really like to know the reason of this weird “regularity”. In fact, if I could figure it out, I would be much more likely to fix the problem. Or at least I would understand it better, which would be useful in any case. :slightly_smiling_face: