Rehearsal mark not aligning with tempo by default

Hi again all,

Occasionally, in situations like these, the rehearsal mark does not want to move up to align with the tempo. Is there a setting that can automatically remedy this at present, or is this only done by manual adjustment in engrave mode for now?

Not currently. You’ll need to manually adjust them in Engrave mode.

There are in fact settings for tempos and rehearsal marks to be aligned together. See the ‘Horizontal Position’ section of the ‘Tempo’ page of Engraving Options. If these options aren’t working as you would expect, perhaps the tempo is attached to a later rhythmic position than the rehearsal mark: both should be attached at the barline/start of the bar.

1 Like

Oops, I whiffed on that one. I searched the forum and all the responses to this request seemed to be “no.” Sorry Andrew!

Hey Dan and Daniel,

Looks like I figured out what’s causing the misalignment, but it has nothing to do with my horizontal position settings, as I’ve tweaked those all and nothing seemed to affect it. It seems that the problem is the “open” direction in the horn line, which when deleted, aligns correctly. When added back in, the tempos shift appropriately (both the rit line beforehand and the tempo marking), but the rehearsal mark does not.


1 Like

That makes sense, as the alignment algorithm is probably only local, and doesn’t take into account other locations.

In such a case, you’d need to align them manually. Is “open” a text item? If so, what happens when you remove its collision avoidance?

Open is a playing technique here. Where can I remove the collision avoidance?

You can’t remove the collision avoidance for a playing technique; that’s only possible for text items. I don’t know whether you’d be open to placing the ‘open’ instruction below the staff?

I don’t think it’s necessary to move the open from where it is. I can manually adjust the rehearsal mark just fine to align with the tempo marking, but I’m still confused why Dorico wouldn’t think to do that itself when it does so in other contexts.

I would need to see the project itself to provide any further insight, I think.

I’ve sent you an email with the file!

Thanks for sending the file. After looking at it and discussing it with the developer who implemented the positioning of tempos and rehearsal marks, I can at least tell you what’s going on. In simple terms, the gradual tempo starting on the previous system, the rehearsal mark, and the immediate tempo following the rehearsal mark are positioned together. The playing technique in the following bar then causes the immediate tempo to move up, and the gradual tempo is also moved up to match, but because rehearsal marks and tempos are not the same kind of item, the rehearsal mark positioner doesn’t get a second bite of the cherry, so the rehearsal mark stays put. This is working as designed for the moment.

Hmm ok. Makes sense from that standpoint. Maybe there is a way to reclassify the rehearsal mark as part of a tempo marking when they exist at the same rhythmic position?

Thanks for the suggestion, but that’s not how the software is designed. I daresay given enough time and priority we’ll be able to improve this in future, but we’re not working on this area of the application at the moment, and nor do I expect it to be something we’re looking at in the very near future.

I was surprised today by the fact that the horizontal alignment options for tempo objects and rehearsal marks only produce the expected result if the minimum distance outside staff option is set to the same value for both.

Is it possible to change this?
That option for rehearsal marks does not consider the enclosure so I usually set it to a larger value, but I still want tempo objects and rehearsal marks to align automatically.

Hello, sorry for rehashing an old thread, I’m working on a project and I can’t get the RM and tempo to align, despite having that option set on my engraving options. No matter what I try, the tempo is always out of whack compared to the RM, and I have to adjust them manually:

Is there any way to fix this?

I wonder if the behavior is connected to the “floating” time sigs…?

I don’t think so, even when I use normal time signatures the problem persists…

What does it look like in Page View?

I recently completed a huge project with 240 or so pages for the conductor’s score, 240 page piano/vocal + 7 separate parts. Moving rehearsal marks which were not aligned to my tempo markings was extremely common and tedious, and almost the most common type of manual editing that I had to do. Daniel’s explanation that they are two different types of object is obviously the reason, but it sure would be nice if you could lock them together.

1 Like