Reinitialize MIDI USB devices without quitting Cubase

Is that possible? Sometimes Cubase loses its connection with the Oxygen 61 USB, is it necessary to close everything, quit and relaunch Cubase?

This is even more inconvenient for me because when Cubase starts up, it remains stuck on “Initializing: MIDI…” for 6 minutes (yes I emailed support about that, no solution).

If anyone has any advice/remark on this… thanks.

No, tried Trashing Prefs?

While trying to solve the “Track inspector doesn’t respond to mouse clicks” problem, I removed the entire C:\Users*Your Username*\AppData\Roaming\Steinberg folder. Cubase was still stuck on “Initializing: MIDI” for 6 minutes.

I asked Steinberg support if Cubase could (like many programs) write a startup log during initialization. I could then see on which USB/MIDI device Cubase was getting stuck.

But the support guy didn’t tell me if Cubase can write that startup dump (so I suppose it can’t), he just told me to unplug the USB MIDI devices one by one and see if it solved the problem. It doesn’t.

Could it be a bad USB port? Worth checking into.

Are we to guess how many MIDI devices you have connected to the system and what they are specifically? :confused:

There is no way to have this happen unfortunately. There is times where I start up Cubase and forget to turn on my midi controller before hand and am forced to quit Cubase, power on my controller then start Cubase back up because it won’t find it any other way.

I do believe this is a Cubase thing and always has been. I heard other DAW’s don’t have this issue.

The only MIDI devices connected are two keyboards, an M-Audio Oxygen 61 and a Korg microkontrol. I have had them both for a long time and Cubase wasn’t getting stuck during startup.

I don’t remember exactly when the problem began, but it was with Cubase 5; maybe it was after some Cubase 5 update, or after some hardware change in my computer although I can’t see which could have had an effect on this.

I suspect it’s not related to these two MIDI keyboards, it could be Cubase checking each USB port to see if a MIDI device is connected to it, and the checking on one of these makes Cubase stall.

Yes, maybe there is a “bad USB port” somewhere but how do I check that? The two keyboards work, so the USB ports they are connected to should be OK.

I just changed the USB ports that both keyboards are connected to, and the problem persists.