relative encoders not working as they should

I have the midi controller arturia minilab which has relative (endless) encoders. They work fine in their own software, meaning no jumps in values.

In Cubase the “knobs” on the screen always jump to the last value of the knobs on the controller, rather than increasing or decreasing. I have tried all kinds of flags in the remote controller setup in cubase, but to no avail. It always jumps which makes the whole thing rather pointless.

Minilab has its own midi setup software but this can’t be run at the same time as cubase, and in any case seem to have no effect on cubase at all.

Anyone?

Does anyone have this problem, or have solved it? It is not very clear in the manual how to use the flags. I’ve gotten some progress when I use all flags, but only on quick controls. It doesn’t work on remote control.

Who would know how this works? I’ve found no relevant info on this online, nor in the manual.

Hello Samuel,
I’m actually setting up my MIDI controller at this moment. I was trying to use the rotary encoder endless function, but that didn’t work at all, so now I have them set up as Track Quick Controls with absolute values 0 - 127. Since Cubase will recieve from as well as send to the Controller, the rotary encoders are always at the correct position. I wanted to avoid the QC (I can’t just right click any knob in a plugin), but for now it will work in my setup til I can figure out something better.

Cheers! That is my solution as well after a lot of tries. And the flags I used in order for this to function is Receive, Transmit, and Relative. Basically all of them, also making sure my controller both sends and receives midi.

Yes, midilearn doesn’t work and that is a shame. but I figured with both “track quick control” and “vst quick control” you at least have 16 knobs (if your controller does - mine does) and that is always something. You can then configure those quick control sets and save them. But it takes a hell of a lot more time figuring out what those controls are on for example omnisphere synths since there are no names, but only numbers, in the quick control panel.

I feel this should be a lot easier…

If someone knows how to make midilearn work properly as well that would be swell.

Hi everyone!

The minilab comes with all the knobs (except number 1 and 9) set to absolute mode. To make them work as expected in Cubase, they should be set to mode “Relative #2” in the “MIDI Control Center” software from Arturia.

After setting up the knobs to the mode “Relative #2”, you can set up an action for each knob inside Cubase by going to Studio > Studio Setup > Add Device > Generic Remote. Make sure to use the flags “Receive” and “Relative” when assigning the knobs to a certain action (use only those).

Hope it helps someone!

1 Like